Lollipop Experimentation (looking for volunteers)

J.Naw Post time 2016-1-25 04:43:13 | Show all posts  Close [Copy link]
1 5802
View: 5802|Reply: 1

Lollipop Experimentation (looking for volunteers)

 Close [Copy link]

7

threads

66

posts

276

credits

Platinum Member

Rank: 3Rank: 3

credits
276
Post time 2016-1-4 11:38:30 | Show all posts |Read mode
Edited by J.Naw at 2016-1-8 08:20 \n\nI AM NOT RESPONSIBLE FOR ANY BRICKED PHONES/EXPLODED DEVICES, ETC. ATTEMPT AT YOUR OWN RISK. READ ALL LINKS.

Downloads:

Using the ROM provided by UMI: http://bit.ly/1O26W9A
Thread for ROM stuff: http://community.umidigi.com/thread-628-2-1.html\
MTK firmware download:
http://mtkfirmware.com/firmware-downloads
Porting tool:
http://d-h.st/OpE           Original Link   Doesnt support 6752, but maybe someone could tinker with it to port over proper files?
(LINKS FOR MT6589 Modems. May work https://drive.google.com/open?id=0B_ujRmp9xyW_SDZVQU1QNlljTkE) Original Kitkat Modem: https://drive.google.com/open?id=0B_ujRmp9xyW_T21Gam91VjhxZVE

HOW TO FIX IMEI 0000000000000000000
https://www.youtube.com/watch?v=UZzZ0yhkxX0

HTC DESIRE d820s:
Boots, but black screen. Computer picks up phone with directories. Tried with kernel from the Umi 5.0 and 4.4.4, Bootloop.

UMI 5.0:
Installed TWRP 2.8.7.0 (http://www.mediafire.com/downloa ... 0_2015-07-18_5.0.7z)
Tried using a different secro.img. (Apparently Provides IMEI and Baseband) But nothing happened.
Flashed Gapps through TWRP, camera dissapeared, and installing google camera comes up with error: "Cant connect to camera"

Alcatel Flash Plus
Doesnt even boot.


Ideas to try:



  • Obviously is a baseband issue. "MOLY.LR9" is for kitkat, whilst the other is "MOLY.WR9.W****"
  • Try to rename Modem files? (Modem_1_ltg_n.img -> Modem_1_lwg_n.img) or when porting Kitkat Modem, vice versa?
Works!! Baseband sucessfully changed from TCL's moly to unknown. now we just need to find a correct MODEM for the bloody thing.
Tried EVERY single modem i could find, Renaming, everything, Still doesnt work...

Original Kitkat Modem: https://drive.google.com/open?id=0B_ujRmp9xyW_T21Gam91VjhxZVE

Possible kernel??????
https://android.googlesource.com/kernel/mediatek/


Turns out the TCL M2M does not support UMTS. This may be part of the issue why the sim does not find a network (Simcard is found though.)
Read screenshot description for modem type. Umi Modem Shows bands enabled under UMTS. in the TCL modem. None are selected and are greyed out.
[size=40.8106px] COMFIRMED
  • Possible fix: Change out the MTKengineering mode APK (*#*#3646633*#*#)
  • Another fix. Backup KITKAT nvram. Restore on 5.0
  • Another fix: need a mt6752 phone ROM which supports wcdma. (Jiayu s3. TCL m2m 3s)

Stock 4.4.4 modem

Stock 4.4.4 modem

TCL M2M 5.0 modem. (Doesn't find network)

TCL M2M 5.0 modem. (Doesn't find network)

7

threads

66

posts

276

credits

Platinum Member

Rank: 3Rank: 3

credits
276
 Author| Post time 2016-1-25 04:43:13 | Show all posts
Edited by J.Naw at 2016-1-25 04:45 \n\nSO! BIG NEWS. Found a source for the Sony Xperia C4 MT6752: http://developer.sonymobile.com/ ... 5-and-27-2-b-0-155/

And the C5: http://developer.sonymobile.com/ ... 87-and-29-1-b-0-87/
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list