UMIDIGI F2 E_V1.0_20200116.V3.06 ROM - SPFT + OTA release

bencebacsi Post time 2020-1-22 23:09:55 | Show all posts [Copy link]
46 9848
View: 9848|Reply: 46

UMIDIGI F2 E_V1.0_20200116.V3.06 ROM - SPFT + OTA release

[Copy link]
Post time 2020-1-19 00:35:16 | Show all posts |Read mode
This is the SP Flash Tool + OTA release of the
V1.0_20200116.V3.06 system software
for UMIDIGI F2
European version


Flash tool operation is recommended to experienced users only. If you are not yet an experienced flash tool user, please carefully read the flash tool tutorial before proceeding, and strictly follow each instruction.

Except if an authorized or responsible expert directly asked you to do that,
never format the flash chip of your device or you instantly lose your warranty!

UMIDIGI F2 receives all updates automatically via FOTA method. You need this tool only in case of emergency (if you've bricked your phone), if you want to apply a clean install or if you want to clear all root access and custom recovery to make your phone able to receive FOTA updates again. Moreover, flashing with SPFT is the only option to repair (replace) damaged system software.




Changelog:
  • HDR effect optimized
  • Wireless signal issues fixed
  • Issue of auto restart of some apps fixed
  • Minor bug fixes and system improvements


FOTA version: UMIDIGI_F2_E_V1.0_20191128_20200116-2101
--------------------------------------------------------------------------------
SP Flash Tool
Resources:


Flashtool tutorial: http://bit.ly/SPFTguide

Extract the .rar file before use. The scatter file (MT6771_Android_scatter.txt) is inside the extracted folder, together with the other components


VCOM driver: Windows 10 can automatically install it. Please make sure that your Windows is logged in with administrator rights and your computer has a working internet connection when first time connecting your phone.


Here's an optional solution to start the flashing process on your UMIDIGI F2 if the standard method doesn't work.
It's especially useful if your phone is bricked or is stuck in bootloop
1. Connect your UMIDIGI F2 to USB.
2. Start the flashing process with the Download button in the flasher app.
3. Press and keep pressed the power button of your phone until the flashing process starts (red bar appears at the bottom of the app window), then release it. In this process you have to keep the power button pressed for about 10 seconds.
4. Wait until the flashing process finishes.

--------------------------------------------------------------------------------
OTA (recovery) update
Manual (local) OTA update method instructions
  • Copy the downloaded .zip file to the internal storage of your phone
  • Go to Settings → System → About phone → Wireless update
  • Tap the 3-dot menu button in the top right corner and select Local Updates
  • Brows for the ...update.zip file and select it
  • Select INSTALL NOW, then OK in the Warning window. Your phone reboots into recovery, the update gets installed, then your phone boots into Android. Your updated system is ready to use.

Update file for manual OTA update:
It can update version 20200109 only

Optional method (in case if the manual OTA update gets stuck): Install from recovery
You need a microSD card (with at least 4GB capacity) installed in your phone!
  • Copy the ...update.zip file to your SD card.
  • Press and hold the volume-up and power buttons together until your phone restarts in the boot selector mode. It needs about 10 seconds or a little bit less if your phone was already powered off.
  • Here you can move with the vol-up button and select an item with vol-down. Select Recovery.
  • Your phone boots into Recovery and you see a lying android figure with an exclamation mark in red triangle on its tummy + 'No command'.
  • Press and hold the power and vol-up buttons (in this order) together, then release them to call the recovery menu. Now you can move with both volume buttons, and select an item with the power button.
  • Move to ‘Apply update from SD card’ and select it.
  • On the next screen brows for the update file and select it. The update process will start and needs a few minutes to be finished.
  • After a succcessful installation, you can read the ''Install from SD card complete.'' message and the recovery menu is available again.
  • Select 'Reboot system now'. Alternatively you can perform a factory data reset here by choosing 'Wipe data/factory reset'

Kind request from users:
Please report any kind of new issues you experience after installing this update only if you've already flashed this ROM with SP Flash Tool in Firmware Upgrade mode. In rare cases a FOTA update can cause more or less serious malfunctions but that means only the update process went wrong, not a badly developed ROM. An updated stock ROM, especially related to the basic functions will not cause any new issues but will solve some of the existing ones.

0

threads

5

posts

18

credits

New Member

Rank: 1

credits
18
Post time 2020-2-20 22:20:01 | Show all posts
@bencebacsi

Some of us are still old school and login with a pin. Please could you make it so that after you have entered the last digit it automatically logins opposed to having to press the tick/arrow.  The Umidigi F1 works in this way.

Many Thanks

0

threads

2

posts

14

credits

New Member

Rank: 1

credits
14
Post time 2020-1-24 20:32:53 | Show all posts
Hi Guys

I have a problem with video recording.
After each record i cannot play video back because it is one big lag.
Let's say i recorded 30 seconds movie and when i tried to open it, it shows 4.56 min instead and it is lagging all the time so i cannot watch is properly
Any help with that ?

Regards

Comments

I have same problem too. In the meantime, try 720p video, not fullhd  Post time 2020-1-29 18:43

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2020-1-23 23:46:56 | Show all posts
Please!!! Make a lowest volume much lower!! It is to loud for silent night. It most important to grade the lowest differences instead of maximnum volume.

4

threads

19

posts

90

credits

Senior Member

Rank: 2

credits
90
Post time 2020-1-19 21:10:33 | Show all posts
Any audio out of the headphone jack is very bad quality, 16-bit or worse! Please fix this ASAP.

0

threads

1

posts

6

credits

New Member

Rank: 1

credits
6
Post time 2020-2-11 02:48:55 | Show all posts
There is one problem;
UMIDIGI F2, when you call viber or whatsapp in these messengers, you can only hear the other person on speakerphone or in headphones, you can't hear them in a normal speaker, it's not very convenient. And sometimes it works, but more often it doesn't, I reinstalled the programs, updated three firmware versions, did a reset, and it doesn't help. Thank you in advance for your response.

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2020-2-19 10:39:00 | Show all posts
There hasn't been an update for a while, thought I would check around and found this forum page.
This should be posted on FB or other social platforms, so we can report bugs or problems.

Phone Issues:
- When accepting or making calls, the microphone does not work, have to use headphones or Bluetooth earphones.
- Lowest volume is not low, it's quite loud, have to turn most apps and games to the lowest volume like 5%.

- Camera has a few problems:
    - Panorama is atrocious, it does not work at all.
    - Front facing camera, the colour changes dramatically when changing light slightly.
    - Low-light photos, late afternoon, photos show some sort of grid pattern on photos.
    - Portrait mode (no depth data or can't adjust focus later like others)
    - Macro, not sure if it's just a fixed focus only, quite hard to maintain distance and be stabilised, I like the macro feature though.
    - On video mode, auto-focusing is continuous but it loses focus really easily.
    - No EIS on Video mode
    - Video playback on recorded video is laggy, plays slightly better on VLC player.

Other issues:
Signal seems weaker for mobile data, I did not have any problem indoors at my work place but now it seems to be really bad. Not sure if using dual-sims affected it or damaged but, even switching back to just one, the data side just become 3Gx or 4Gx and shows 'No Internet'.

Not software issue but the plastic or frame around the fingerprint button has a small crack on both sides when I haven't even dropped it.

0

threads

1

posts

10

credits

New Member

Rank: 1

credits
10
Post time 2020-2-16 13:54:48 | Show all posts
Edited by gowlijk at 2020-2-16 14:09  

Dear Team, I am facing problem on the bleow issues as these activities are my daily routine.
Audio Jack :  I am unable to play audion using headphone, there is no audio output/ No Sound even after the Phone shows the headphone is connected. --- Please Fix.
Video playback : After recoeding the video, when I play on my F2 the video lags and cannot watch it. whereas if i download it on laptop it plays fine.  ---- Please Fix.
Camera error :  during potrait pictures, some are good and some are worst, the face colour changes it dark. also the camera application has not much features to adjust the camera.  ---- Please Fix.
SD Card : Files option storage device doesn't show the SD Card and the usage size of it.  ---  Please Fix.


Regards

Comments

I'm having this same problem with video playback. I tried to upload a log file to the Umidigi bug reporting page but the file is too big and won't upload. Umidigi, please fix video playback on the F2  Post time 2020-2-20 03:32

0

threads

21

posts

136

credits

Senior Member

Rank: 2

credits
136
Post time 2020-1-20 20:57:55 | Show all posts
Edned replied at 2020-1-19 21:10
Any audio out of the headphone jack is very bad quality, 16-bit or worse! Please fix this ASAP.

Same. They know about the issue, but the question is whether it will be fixed or not.

In the meantime, go to Settings -> Sounds and turn on Touch Sounds. You will hear feedback when you tap the screen, but it keeps the equalizer service alive and hardware presets fed, so the headphone quality will be restored.

0

threads

7

posts

24

credits

New Member

Rank: 1

credits
24
Post time 2020-1-19 21:17:48 | Show all posts
Edited by DaGrooveNL at 2020-1-20 02:44  

Hi Umidigi team,

I got a weird issue where my Umidigi F2 keeps disconnecting from WiFi every ~20 minutes and after that I'm unable to reconnect to WiFi. It does not matter which WiFi access point I try to connect to. If I turn off WiFi on my phone and then turn it back on, it then works again for another ~20 minutes before I have to repeat the process again.
All my other devices and phones do not have this issue.

Additionally, there's another weird bug concerning Bluetooth. After about ~5-10 minutes I am unable to make calls via Bluetooth in my car, if I turn off Bluetooth and turn it back on, then it works again.

I'm on the latest version, but I've not yet tried restoring the version via the Flash tool. I'll try this now and revert back to you guys later.
EDIT: Using 'Download Only' mode, does not resolve the above mentioned issues. I will now try the 'Firmware Upgrade' mode and revert back here.
EDIT2: Using 'Firmware Upgrade' mode (with wiping userdata) even made the issue worse, during setup of the phone, I lost WiFi connection within 2 mins and after that I was no longer able to connect to any WiFi accesspoint. Turning WiFi off and back on resolved the issue but then after a few minutes it disconnected again.
EDIT3: Regarding the WiFi issues, I've found out that WiFi works fine when you're connected to a dedicated band (e.g. a 2.4Ghz only channel). The phone loses connection when you're connected to a mixed-band (2.4Ghz + 5Ghz). Can you please investigate why this is the case?



If you need more information concerning these issues, I'd be happy to assist

Kind regards,
André

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2020-1-20 19:27:48 | Show all posts
После установки обновления V1. 0_20200116.V3. 06 отключился микрофон! Как исправить???

4

threads

19

posts

90

credits

Senior Member

Rank: 2

credits
90
Post time 2020-1-21 06:27:58 | Show all posts
datboyolly replied at 2020-1-20 20:57
Same. They know about the issue, but the question is whether it will be fixed or not.

In the mean ...

Thank you!

0

threads

21

posts

136

credits

Senior Member

Rank: 2

credits
136
Post time 2020-1-21 10:53:29 | Show all posts
DaGrooveNL replied at 2020-1-19 21:17
Edited by DaGrooveNL at 2020-1-20 02:44  

Hi Umidigi team,

That's a hardware problem unfortunately. Open up a request to your seller for a repair or replacement. Tell them WiFi and Bluetooth keep disconnecting, that the problem is getting worse, and you have done two (or more) factory resets without any success.

0

threads

7

posts

24

credits

New Member

Rank: 1

credits
24
Post time 2020-1-22 03:14:03 | Show all posts
datboyolly replied at 2020-1-21 10:53
That's a hardware problem unfortunately. Open up a request to your seller for a repair or replaceme ...

I've found out a way to circumvent the issue with Bluetooth.
I had two devices connected (my smartwatch and carkit) and both were connected with calling-privileges. After removing the calling privileges from my smartwatch, the issues dissappeared regarding the Bluetooth disconnects.

My WiFi is also stable when I'm only connected to 2.4Ghz, but when I'm connected to a mixed-mode signal (so 2.4Ghz + 5Ghz), my WiFi disconnects after a specific time and then I'm no longer able to connect to ANY WiFi. I'm only able to connect to a WiFi after I've disabled WiFi on my phone and then re-enabled it.
This must be some sort of a software issue, where I suppose the WiFi driver gets confused between the channel it should try to connect to (2.4Ghz or 5Ghz) and then this causes some sort of driver crash I assume (since it will not connect to any new WiFi channels until the WiFi adapter is turned off and back on).

@Umidigi team, please investigate this issue regarding WiFi. I'm a software developer myself and I'm willing to provide you any information necessary to resolve this issue.

0

threads

7

posts

24

credits

New Member

Rank: 1

credits
24
Post time 2020-1-22 07:14:01 | Show all posts
After additional testing, I found that the issue seems to be being caused when one physical WiFi connection supports both 2.4Ghz and 5Ghz simultaneously. The reason being, I splitted my own WiFi into two channels (2.4Ghz and 5Ghz), with the same SSID and I'm able to stay connected to it indefinitely, so that works.

However, when I configure the WiFi connection to be one channel (both 2.4Ghz and 5Ghz), the issues appear again. This must be a software related issue, can you please investigate?

0

threads

1

posts

16

credits

New Member

Rank: 1

credits
16
Post time 2020-1-22 23:09:55 | Show all posts
Edited by alexsat77 at 2020-1-23 00:09  

problems in yellow on the front camera under artificial lighting (diode lamps)
I attach 2 photos, one made with 48Mp https://ibb.co/z65vjYR, the other frontal https://ibb.co/44JFy4y.
No camera tinctures help.Photo thttps://ibb.co/XsFvcfZ-shirts from the device Meizu M6 Note
12345Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list