BUGS CONCLUSION

ashkanr65 Post time 2019-2-26 17:37:39 | Show all posts [Copy link]
62 3042
View: 3042|Reply: 62

BUGS CONCLUSION

[Copy link]

1

threads

33

posts

104

credits

Senior Member

Rank: 2

credits
104
Post time 2019-2-25 23:42:30 | Show all posts |Read mode
Edited by ashkanr65 at 2019-2-26 21:15  


If anyone found other bugs, Please add to this thread and then I will update the thread.



UMIDIGI_F1_V1.0_20190125_20190130-1420




  • Phone restart sometimes.
  • Rear camera take bluish photo (even if using pro mode->florescent) "KNOWN ISSUE"
  • In some phones, locations icon doesn't appear on the notification bar
  • Bluetooth cannot connect to Bluetooth Low Energy devices
  • When we try to delete a photo, the pop-up menu is broken!
  • Sometimes when we delete a photo and device show us next photo automatically, the eliminated photo is on the background of the new photo!!!
  • GPS shows my face direction in the opposite way
  • Wireless connection is not stable very well
  • missing engineerMode.apk
  • exfat sd card not supported so can't copy file > 4G
  • Wi-Fi 5GHz does not work on channels 36-48, on channels 52-64 and others it works well
  • erratic behavior of fingerprint sensor
  • erratic behavior of face recognition
  • When I enter my pin correctly I often get the message "pin incorrect" on the screen where I have to enter my phone password, it's very confusing because it gives the impression that you need to enter your pin while the phone expects the password
  • When I switch the phone on, I sometimes have to enter my pin and password twice and screens are also different
  • the NFC does not communicate with merchant EFTPOS terminals
  • Proximity sensor not work
  • If we search "percentage" in the setting, we can find "Battery percentage", but there isn't any option to activate this option even if we click on it


I am trying to update this thread after each update.


We just need a specific date for the update...



Post time 2019-2-27 08:00:11 | Show all posts
Dear ashkanr65 and other users,

You can report any kind of bugs on the following page: https://www.umidigi.com/page-BugReport.html
The bug report page is anytime accessible from the Misc / Development section.
The growing list in the first post of this thread is misleading since it suggest that, all handsets are affected by all the listed bugs (some of them are not even bugs, just well-known technical limitations) while that's definitely not the case. Many factors like a hardware defection, using badly assembled apps, cutoms ROMs or system hacker tools etc. may cause specific issues that can not be addressed by the developers.
This thread will be removed by the end of this week. Please report your specific issues in separated threads, or find an existing thread about the same topic or report your issue in the appropriate thread of the F1 ROM section if you need to report your issue publicly.


  • Phone restart sometimes. - It might be a specific issue of your phone. Please flash your device with SP Flash Tool in Firmware Upgrade mode. If flashing doesn't help, then you might have a defective hardware. Please contact your seller.
  • Rear camera take bluish photo (even if using pro mode->florescent) "KNOWN ISSUE" - Yes, it's a known issue and the developers are working on the solution. Please wait for the next update. That will be released as soon as possible, so we can't tell you a specific date.
  • In some phones, locations icon doesn't appear on the notification bar - That icon will appear only when the locations service is in use, not always when you open an app that has access to your location.
  • Bluetooth cannot connect to Bluetooth Low Energy devices - Please mention some such devices (brand and model) to let us check it.
  • When we try to delete a photo, the pop-up menu is broken! - That happens only if the navigation bar is hidden. It's a bug of the Google Photo app, probably will be fixed in the future.
  • Sometimes when we delete a photo and device show us next photo automatically, the eliminated photo is on the background of the new photo!!! - We can't reproduce your issue. Please take and share a video to let us see how it looks like.
  • GPS shows my face direction in the opposite way - It's not clear what your problem is. Please tell us which app you use and/or take and share a video showing your issue.
  • Wireless connection is not stable very well - That can have numerous reasons but no reviewers or a mass of users reported such an issue until now.
  • missing engineerMode.apk - That's a requirement to get the Google certificate and that app has never been officially supported. Even if it's available, most of its features are not usable anymore, they have no effect.
  • exfat sd card not supported so can't copy file > 4G - MediaTek SoC (any kind) based devices have never supported the exFAT file system, we have nothing to do with it.
  • Wi-Fi 5GHz does not work on channels 36-48, on channels 52-64 and others it works well - We can't confirm your issue and no other users have reported it.
  • erratic behavior of fingerprint sensor - We can't reproduce your issue and no reviewers or a mass of users reported this until now. Please delet your fingerprint sample and set it again but touch the sensor in different angles. You also can try to create multiple samples of the same finger.
  • erratic behavior of face recognition - We can't reproduce your issue and no reviewers or a mass of users reported this until now. Please delete, then enroll your face again in well lit conditions. Then you can use it even in the dark if you enable 'Activate screen fill...'
  • When I enter my pin correctly I often get the message "pin incorrect" on the screen where I have to enter my phone password, it's very confusing because it gives the impression that you need to enter your pin while the phone expects the password - This report is confusing too. So have you set a pin code or pasword for screen unlock? Please make it clear.
  • When I switch the phone on, I sometimes have to enter my pin and password twice and screens are also different - Please take and share a video to let us see how it looks like.
  • the NFC does not communicate with merchant EFTPOS terminals - Are you sure your account holder bank supports that feature? No reviewers or a mass of users reported this issue until now.
  • Proximity sensor not work - If that happens, please reboot your phone. Our developers will look into this case. We can reproduce this issue and is reported by multiple users.
  • If we search "percentage" in the setting, we can find "Battery percentage", but there isn't any option to activate this option even if we click on it - You can see the battery percentage only after pulling down the notification bar. It's not a bug but the percentage might be added to the default notification bar in the future.


0

threads

27

posts

114

credits

Senior Member

Rank: 2

credits
114
Post time 2019-3-2 03:13:30 | Show all posts
I just got the new firmware update and there is a colossal fail

I cannot multitask with any launcher except the stock launcher - trying to press the square when using Nova launcher and I get a Quickstep crash.

Please Umi - sort that out asap?!

Comments

I have submitted a bug report, It is very annoying. worked fine before the march 1st OTA. Overall I am happy with the phone, just a couple of annoying niggles.  Post time 2019-3-2 18:54

0

threads

4

posts

16

credits

New Member

Rank: 1

credits
16
Post time 2019-3-4 19:41:20 | Show all posts
GadgetBeard replied at 2019-3-4 11:45
After the latest update... The multi task button is broken in third party launchers... It will crash ...

I have the same issue with my F1. I tried different launchers and always I get the same error

1

threads

20

posts

63

credits

Senior Member

Rank: 2

credits
63
Post time 2019-3-5 20:08:09 | Show all posts
Edited by ashkan.r65 at 2019-3-6 00:09  

Hi,

I updated my phone days ago and some of the issues are fixed. However, there are some new bugs, which probably you already know about those.

Such as

1.
When the battery goes under 15%, Overview Button make some vibration on the screen, I tried to record a video but the vibration was so fast and another phone cannot record it. But it's easy to test.

2.
Multitasking manager, which Bencebacsi mentioned as a known issue.

3.
In the input pin keyboard, there is a ✅ which is useless.

4.
Other issues are fixed except the WiFi stability. It looks like very weak and is waiting for disconnecting.

5.
WiFi channel wasn't my issue, some of the customers mentioned that and I gathered all of the bugs.

6.
I wrote some ideas on the ROM part which I will write here again:

Some Idea: first instead of Open Camera, please add all of the function to the original phone app
Based on this comment from Bencebacsi:

"Install Open Camera, enable Camera2 API in its settings, and then you can see the shutter speed in the top left corner."


Second please add Slow Motion mode to the phone app.

It will be a good idea if you add double tap gesture to the screen to turn the screen on or off, because using the power button as camera shortcut and also turning Ring mode to Silent Mode, put a lot of pressure on this button. You can also change the camera shortcut.

Put an option to disable mirror mode for frontal camera

And also add some Real Time Retouch photo on front camera! It shows a lot of detail.


Unfortunately, my original account has been removed by Ben(and also blocked on Instagram, so I cannot change the first post, so I added these bugs and ideas here

0

threads

6

posts

24

credits

New Member

Rank: 1

credits
24
Post time 2019-3-5 02:36:07 | Show all posts
bencebacsi replied at 2019-3-3 19:46
I have 12 widgets placed on my home screen of my test device but all of them work perfectly, so I c ...

I've tried to follow your advice, but after removing all non working widgets from my home screen, and trying to add anyone of them again, I got stuck in a middle of an adding process - the system was unable to add widget, nor it was able to signal error. The process of adding widgets ended up in a deadlock.

What helped me to solve this problem, was advice from ashkan.r65, who suggested to disable DuraSpeed (Thanks !)

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2019-3-4 11:45:44 | Show all posts
After the latest update... The multi task button is broken in third party launchers... It will crash the multi task with a "Quickstep has stopped" error message.... From what I understand Quickstep is the name of the stock launcher

0

threads

2

posts

8

credits

New Member

Rank: 1

credits
8
Post time 2019-2-28 17:43:59 | Show all posts
The switched NFC does not work on my Umidigi F1. I tried different apps to read. Also different NFC tags ... credit cards, key chains and stickers.

0

threads

1

posts

30

credits

New Member

Rank: 1

credits
30
Post time 2019-2-28 06:33:42 | Show all posts
bencebacsi replied at 2019-2-27 08:00
Dear ashkanr65 and other users,

You can report any kind of bugs on the following page:  ...

Hi there , in reply to question 16: re the NFC issue , here is my full problem , And yes the merchants DO take Google Pay as explained , the fault is with the F1 somehow , I understand that most global users probably don't use Google Pay but in Australia it is VERY popular running along with Apples , Apple Pay .Hey there , any idea or heard of anyone having Google Pay , I have a One Pro thats works great , and many other Androids etc , but my new purchase , the F1 , will not communicate with merchant EFTPOS terminals , all settings within Google Pay and the phones NFC settings are correct . I even downloaded a NFC test app that has the abilities to read the numbers of any card placed on the back of the phone so I assume the NFC device in the phone is fine , I'm hoping just a bug , but why only me as I can't find any other similar stories / blogs about it online . I live in Australia where their is a big uptake in cardless payments hence I liked the F1 specs , but its kind of hopeless now & I will still need to carry a wallet with my credit / debit cards etc , any info would be great , cheers , Shaun .

0

threads

13

posts

68

credits

Senior Member

Rank: 2

credits
68
Post time 2019-2-28 04:54:33 | Show all posts
also this mtk's band switching has serious issue. I am in NYC and band 2 is super crowded, especially inside building...my brother's oneplus 6 switches to band 17 immediately once inside building. umidigi phones just stuck until you manually turn on/off airmode...both Z2 pro and F1 behave exactly same. But I can lock band for Z2 pro with engineerMode....and no luck for F1 as no engineerMode available...have to say bye bye to umidigi

0

threads

6

posts

24

credits

New Member

Rank: 1

credits
24
Post time 2019-2-28 04:04:49 | Show all posts
Funny thing ... I had problems with proximity sensor and alarms not being raised at all - after leaving phone not being used for few hours. I was really annoyed.

So I decided to :  
1. carefully manage aplications in DuraSpeed to allow them run in background,
2. disable "Intelligent power saving in standby mode",
3. disable all Device Managers,

and ... voila !

Now everything works as it should ! I do not have to recalibrate proximity sensor to get it working, nor I have to "wake up" alarms to let them run at proper time

Currently I am enjoying the phone very much

1

threads

33

posts

104

credits

Senior Member

Rank: 2

credits
104
 Author| Post time 2019-2-26 00:08:28 | Show all posts
If anyone found other bugs, Please add to this thread and then I will update the thread.

0

threads

13

posts

68

credits

Senior Member

Rank: 2

credits
68
Post time 2019-2-26 02:39:22 | Show all posts
missing engineerMode.apk
exfat sd card not supported so can't copy file > 4G

0

threads

11

posts

40

credits

New Member

Rank: 1

credits
40
Post time 2019-2-26 04:06:52 | Show all posts
I would add:
- erratic behaviour of fingerprint sensor
- erratic behaviour of face recognition
- no red bubble notifications when receiving a new message (while it is enabled), it doesn't work with gmail, sms application, facebook, ...
- sometimes goes back to main screen while I'm typing a message

1

threads

33

posts

104

credits

Senior Member

Rank: 2

credits
104
 Author| Post time 2019-2-26 07:12:13 | Show all posts
dadainnyc replied at 2019-2-26 02:39
missing engineerMode.apk
exfat sd card not supported so can't copy file > 4G

They are added

1

threads

33

posts

104

credits

Senior Member

Rank: 2

credits
104
 Author| Post time 2019-2-26 07:20:59 | Show all posts
klintistwood replied at 2019-2-26 04:06
I would add:
- erratic behaviour of fingerprint sensor
- erratic behaviour of face recognition

1- Fingerprint cannot recognize your finger when your fingers are wet (it is a common problem between all phones) however fingerprint module will be work better if you remove the phone case.
2- it doesn't work like Apple or other flagship phones.
3- When we bought it, we already knew that it doesn't have a red light. problem with gmail, SMS, facebook, WhatsApp ... related to android pie and battery optimizer. It will learn from you and work better after a while.
4- I have the same issue, but I found that it related to "Slippery Gesture". actually, when you press space on your keyboard, your finger movement is like home button and Android assumes that you want to go to home screen. I think it's related to Android gesture.

0

threads

90

posts

660

credits

Diamond Member

Rank: 4

credits
660
Post time 2019-2-26 15:51:05 | Show all posts
Wi-Fi 5GHz does not work on channels 36-48, on channels 52-64 and others it works well.

0

threads

11

posts

40

credits

New Member

Rank: 1

credits
40
Post time 2019-2-26 16:18:01 | Show all posts
ashkanr65 replied at 2019-2-26 07:20
1- Fingerprint cannot recognize your finger when your fingers are wet (it is a common problem betw ...

Hello Ashkanr65,

My fingers are perfectly fine, I buy 5-6 phones every year for my blog and the Umidigi F1 is the only one where I have this kind of issue. In exactly the same conditions, the sensors sometimes work, sometimes it doesn't. Same for face recognition.

I would also add:
- When I enter my pin correctly I often get the message "pin incorrect" on the screen where I have to enter my phone password, it's very confusing because it gives the impression that you need to enter your pin while the phone expects the password
- When I switch the phone off, I sometimes have to enter my pin and password twice and screens are also different

1

threads

33

posts

104

credits

Senior Member

Rank: 2

credits
104
 Author| Post time 2019-2-26 17:35:33 | Show all posts
lobyte replied at 2019-2-26 15:51
Wi-Fi 5GHz does not work on channels 36-48, on channels 52-64 and others it works well.

your bug Added

1

threads

33

posts

104

credits

Senior Member

Rank: 2

credits
104
 Author| Post time 2019-2-26 17:37:39 | Show all posts
klintistwood replied at 2019-2-26 16:18
Hello Ashkanr65,

My fingers are perfectly fine, I buy 5-6 phones every year for my blog and the U ...

Ok, with your explanation I added your bugs too. Thanks man.
123456Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list