UMI Emax Power ON Fail?

montonn Post time 2015-10-17 01:05:46 | Show all posts [Copy link]
8 1441
View: 1441|Reply: 8

UMI Emax Power ON Fail?

[Copy link]

1

threads

1

posts

63

credits

Senior Member

Rank: 2

credits
63
Post time 2015-9-22 19:06:19 | Show all posts |Read mode
My eMAX power on No Work. But I charge battery LED Red On?
I push power on Emax No Open and LED Red off.
I Buy New UmiEmax 3 week.
My Emax Fail?


2

threads

11

posts

91

credits

Senior Member

Rank: 2

credits
91

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-10-11 20:21:06 | Show all posts
I have the same problem. PLEASE hElp!

2

threads

11

posts

91

credits

Senior Member

Rank: 2

credits
91

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-10-11 20:25:43 | Show all posts
More details:
it was full charged. I left it forr a couple of hours and when I wanted to used again it seemed to be off.
But from there on it has been impossible to turn it on!! Any way to reset it?
What can I do? I bought it two months ago!

2

threads

11

posts

91

credits

Senior Member

Rank: 2

credits
91

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-10-11 20:37:21 | Show all posts
Buf! It is on again!
What I have done is to start it pushing on button+volume up
I entered in update mode and I have selected reboot and this time it worked.
Anyway I am worried about this.
Can this happed suddenly with no cause? It is related to a ROM problem?
Post time 2015-10-14 19:55:48 | Show all posts
Edited by bencebacsi at 2015-10-24 10:45 \n\n

It seems to be a unique issue. When you were not able to power on your phone, did you try to connect to USB? You spoke about the red LED but could you also see the battery charging animation on the screen or it was keeping black?

0

threads

2

posts

17

credits

New Member

Rank: 1

credits
17
Post time 2015-10-15 00:52:12 | Show all posts
Hello i have exact the same problem with my Umi phone.
Bought in June and since 2 weeks i have this power issue.
Battery is fully charged and suddenly the phone is offline when i check later.
Can only startup with vol + and power on nothing else work.
Battery charging does not display on the screen, it stays black and first the red led is on but later off.

What can i do, it did happen 4 times and the phone is not realiable in this way, for the rest there where never any problems.

To bad battery cannot be taken out, is it bad.?

Thanks
Post time 2015-10-15 02:20:57 | Show all posts
I've reported this issue to UMI. To solve your problem, try to process a full flash upgrade with the SP Flash Tool version of the V05 firmware

0

threads

2

posts

17

credits

New Member

Rank: 1

credits
17
Post time 2015-10-16 23:23:55 | Show all posts
Hello bencebacsi, thanks for your tip.
However i did reflash my phone with v05 firmware yesterday and this morning the power failure problem did happen twice.

Had to start with vol+ and power on after a while it did boot.
The battery is embedded in this phone i cannot disconnect.
What can i do , sent the phone back to UMI .?
Thanks very much.
Post time 2015-10-17 01:05:46 | Show all posts
Hi phoney,

I suggest you to charge your phone with another wall charger and USB cable. If that's no effect, then yes, you should send back your phone for a replacement, but not to UMI but to the reseller from whom you received your device originally. The issue might be caused by a contact problem of the power on button or a weird defection of the power handling system.
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list