Iron does not detect Simcard anymore

VlskDrw Post time 2015-9-2 10:28:50 | Show all posts [Copy link]
22 7638
View: 7638|Reply: 22

Iron does not detect Simcard anymore

[Copy link]

1

threads

3

posts

16

credits

New Member

Rank: 1

credits
16
Post time 2015-8-17 00:31:18 | Show all posts |Read mode
I have used my Umi Iron for 2 days now and so far I really like it! I was getting used to everything and wanted to continue the setup.

So, today, I was using it normally and I went to check it and it said that the simcard is not inserted. I did not do anything! It just said it all of a sudden. I went ahead and switched it around, replacing the slots, taking it out again. I restarted my phone a few times, but still it says no Simcard is inserted.

Its really frustrating because I cannot used the phone at all!

Any helpers?

15

threads

23

posts

180

credits

Senior Member

Rank: 2

credits
180

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-9-1 15:10:29 | Show all posts
Edited by s7yler at 2015-9-3 05:47 \n\nI actually have a similar problem, but it is a ROM/software problem in my case.
Can you please try to check with ROM v1.0.... and to others, what ROM version are you using?

16

threads

212

posts

620

credits

Diamond Member

Rank: 4

credits
620

UMIDIGIerDie-Hard UMIDIGI Fans

Post time 2015-8-31 11:42:16 | Show all posts
Hi all,

Just a question... how many of you having issues have used a nano sim that was cut to size rather then a newly issued nano sim?

Cheers,
Gruffles

0

threads

8

posts

139

credits

Senior Member

Rank: 2

credits
139

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-8-17 07:08:46 | Show all posts
Edited by grzebzi at 2015-8-18 22:01 \n\nIt seems like quite a few people have such an issue.

I use nano SIM and micro SD 32 GB card, and it happens sometimes that both dissappear.
It shows me "no sim card" and "sd card has been removed" at the same time.
After putting some presure on screen, just where te SIM slot is, it finds them both.
It's quite annoying, while  you never know when SIM is disconnected.
Sometimes all is OK for about 8 hours, and then it can disconnect couple times within 10 minutes.
No matter ROM version (same on 1.4 and 1.5).

The problem might be caused by 3 things:
1. the SIM/SD slot used - it can be a bit to thick for thin SIM card so that contact is sometimes lost (I'm currently checking on that - I've put a paper address sticker on SIM and SD card and cut it to the size of cards to make them a bit thicker. We'll se if it helps. If so, I'll let you know in couple hours/days.)
2. software issue - then it would be up to UMI to fix that
3. hardware problem during soldering process - some cold joints could cause it

I hope it's not no. 3 because it would be a major problem for UMI. I'm not sure if there is a multi-layer PCB on Iron and how is it made (fully automated or human assisted).

Maybe some UMI engineer could tell us more about this problem. Maybe there is already some fix/workaround. I'll let you know when I finish my "research".

Best regards.

1

threads

3

posts

16

credits

New Member

Rank: 1

credits
16
 Author| Post time 2015-8-17 13:05:52 | Show all posts
I updated Android to 5.1 but that didnt change anything. My Iron still says "no sim card"
It dies recognize the SD card which i also have inserted.
So, it looks like the Pins for the SD card are ok, right?

0

threads

8

posts

139

credits

Senior Member

Rank: 2

credits
139

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-8-18 21:10:53 | Show all posts
Almost 22 hours without disconnection and then, suddenly, whet taking the phone out of my pocket - ka boom - no SIM card, no SD card.

I've made some more tests, and results are far from satisfactory.

It appears that SIM and SD disconnections are caused by slot, cards tray and the back cover.
It seems that when the back cover is mounted it pushes the outer (the one with ejecting hole) side of tray up (towards the screen) which causes disconnections.

When the back cover is removed, disconnections happen virtuall ever (only when I try to move the tray in slot). It is also strange tha such sligt movements cause disconnection.

Puttng sticky paper on SIM and SD card helps a bit, it stabilizes them in the slot, but disconnection will eventually happen sooner or later. The only solution is to take the tray out and slide it back again (but not to deep, because it won't work).
It seems that this kind of slot is a very bad idea, the phone is barely usable.
There is no such problem on eMAX where you put cards without any tray.

IMHO the solution could be redesigned tray which would prevent any SIM and SD movements.
Otherwise near every Iron would have to be rplaced/repaired.

It would be nice if someone from UMI answered on this.

Best regards.

4

threads

58

posts

216

credits

Platinum Member

Rank: 3Rank: 3

credits
216
Post time 2015-8-31 11:30:38 | Show all posts
Thank you for your knowledge and findings grzebzi. My SD card has never worked - ever and reading your posts has made me decide to return this phone and get something else.

I love the phone but the dual-purpose sim tray is too poorly designed and I can see that this is going to cause major problems over time.

It was a nice idea but I don't think Umi tested it thoroughly enough before placing the phones in the hands of the consumer.

Very disappointing indeed.

3

threads

186

posts

633

credits

Diamond Member

Rank: 4

credits
633

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-9-1 19:15:42 | Show all posts
Thanks for your share S7yler. Can you downgrade your phone to V1.0 to be sure your simcard is well recognize as at the beginning. Because your phone can have been damaged.
Thank you

0

threads

1

posts

23

credits

New Member

Rank: 1

credits
23
Post time 2015-9-2 04:01:22 | Show all posts
My second slot never worked. Always says "SIM empty" no matter what...

16

threads

212

posts

620

credits

Diamond Member

Rank: 4

credits
620

UMIDIGIerDie-Hard UMIDIGI Fans

Post time 2015-9-2 10:28:50 | Show all posts
bencebacsi replied at 2015-9-2 09:31
Do you try to use a cropped or an original nano SIM card?

This goes for all people with sim issues. We've asked this a few times and no one has answered this question. This may at least give us some insight as to what is causing the issue.

Please, everyone who is having sim issues, can you tell us if your nano sim is cut to size from a full size/micro sim or if it is a newly issued nano sim?
123Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list