Camera noise fix patch

cloudvdr Post time 2016-4-19 14:45:52 | Show all posts [Copy link]
34 4900
Author: cloudvdr

Camera noise fix patch

[Copy link]

5

threads

274

posts

1744

credits

Diamond Member

Rank: 4

credits
1744
Post time 2016-4-11 14:00:15 | Show all posts
Edited by rhen at 2016-4-11 16:04 \n\n
Can you post a before-after picture to show the difference?
This "fix" is for the noise only?
I'm at the final stage of the audio fix 2.0 and my next project will be the lens shade and color correction of the images. I'm more bothered with this since it changes the mood of the picture and seen even if you don't zoom in.
There is no ETA since I currently have so many important stuff going on in life, but it is planned.

Comments

Yes, that's why I tried liveboot to see if it's the same. And it is, so this fix will probably work on it too.  Post time 2016-4-11 16:32

1

threads

16

posts

96

credits

Senior Member

Rank: 2

credits
96
Post time 2016-4-11 16:00:57 | Show all posts
Interesting, I have Iron Pro and it seems camera issue is the same. I just tried liveboot to get boot log and this is what I get

D/ImgSensorDrv(  291): [impSearchSensor]found <0xd850/imx214mipiraw/SENSOR_DRVNAME_OV13850_MIPI_RAW>

Comments

Iron Pro is the same phone with a fingerprint reader. The USB Type-C is just the form factor of the connector. See: https://en.wikipedia.org/wiki/USB_Type-C#USB-IF_specifications  Post time 2016-4-11 16:12

1

threads

16

posts

96

credits

Senior Member

Rank: 2

credits
96
Post time 2016-4-11 16:38:15 | Show all posts
Sorry, commented on wrong post, didn't know I can't comment on mine so comment link was for your post instead of mine.

1

threads

33

posts

377

credits

Platinum Member

Rank: 3Rank: 3

credits
377
Post time 2016-4-11 23:13:11 | Show all posts
Thank you for your efforts, cloudvdr! so the patch is updated on first post? or has to be posted yet?

6

threads

67

posts

313

credits

Platinum Member

Rank: 3Rank: 3

credits
313
 Author| Post time 2016-4-14 03:48:34 | Show all posts
Sorry, I did not have time this days... on 1st post i upload the link with new libcameracustom, but REMEMBER: ONLY WORKS ON v1.6 ROM

1

threads

33

posts

377

credits

Platinum Member

Rank: 3Rank: 3

credits
377
Post time 2016-4-19 00:32:27 | Show all posts
wish I could downgrade from 1.8 to test it, but i'm not on pc right now.
Can we have some pictures done before/after with both cameras? would be great to see how the situation improves!

5

threads

274

posts

1744

credits

Diamond Member

Rank: 4

credits
1744
Post time 2016-4-19 01:01:29 | Show all posts
benson replied at 2016-4-19 00:32
wish I could downgrade from 1.8 to test it, but i'm not on pc right now.
Can we have some pictures d ...

You don't need a PC to do it.
Download the ROM from here: [link]
Then install it via TWRP.

Anyway, I'm also curious about the effect. I would be good to see the before after pictures.

6

threads

67

posts

313

credits

Platinum Member

Rank: 3Rank: 3

credits
313
 Author| Post time 2016-4-19 04:44:19 | Show all posts
I am so sorry, but before i did not use the stock camera... I used to take photos with lenovo snapit camera and htc m8 camera ports...

6

threads

67

posts

313

credits

Platinum Member

Rank: 3Rank: 3

credits
313
 Author| Post time 2016-4-19 04:49:57 | Show all posts

5

threads

274

posts

1744

credits

Diamond Member

Rank: 4

credits
1744
Post time 2016-4-19 14:45:52 | Show all posts
I don't see big improvement on this, but the colors...
It still sucks.
I've started the work on a fix for this, but it is more complicated than I first thought.

Comments

I don't know, it looks better to me. True, I don't have Iron, but Iron Pro, although camera has the same "problem". Pictures that I take outside on sunny day have way more noise than this one   Post time 2016-4-21 16:44
1234Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list