UMIDIGI F2 V1.0_20191221.V3.06 ROM - SPFT + OTA release

bencebacsi Post time 2020-1-4 03:13:30 | Show all posts [Copy link]
73 4299
Author: bencebacsi

UMIDIGI F2 V1.0_20191221.V3.06 ROM - SPFT + OTA release

[Copy link]

0

threads

14

posts

92

credits

Senior Member

Rank: 2

credits
92
Post time 2019-12-30 04:54:35 | Show all posts
Anyone else have nothing showing up under battery usage? No matter how long I use it, or charge, it always shows empty information.

Comments

yep, nothing shows up  Post time 2020-1-4 02:58

0

threads

14

posts

92

credits

Senior Member

Rank: 2

credits
92
Post time 2019-12-30 13:20:41 | Show all posts
Daguiarmx replied at 2019-12-26 11:45
Edited by Daguiarmx at 2019-12-28 00:45  

Video recording is very choppy, like the frame rate is n ...

I don't have a problem with my 3.5mm jack. If yours is not working it might be hardware problem.

0

threads

21

posts

136

credits

Senior Member

Rank: 2

credits
136
Post time 2019-12-31 08:13:14 | Show all posts
Daguiarmx replied at 2019-12-26 11:45
Edited by Daguiarmx at 2019-12-28 00:45  

Video recording is very choppy, like the frame rate is n ...

Your 3.5mm headphone jack problem is caused by an equalizer app. The problem is even persistent after a factory reset!

I used "Equalizer FX" which conflicts with com.android.musicfx. It seems Umidigi are relying on this app to permanently equalize the output of the headphone jack.

So for me, I had to:
1. Restore to factory default
2. Start playing music through speaker
3. Plug in headphones while music playing through speaker
4. No output via headphones, as expected
5. Pause music, keep headphones plugged in
6. Go to Settings -> Sound -> Advanced -> Sound enhancement
7. Toggle BesLoudness on, then off
8. Restart the phone

I didn't notice any difference in the speaker output while Equalizer FX was installed, but certainly, the headphone output was just a mess. Permanently distorted, then stopped working. I presume that Droi (the actual manufacturer) just threw together some hardware change settings inside musicfx to make the headphone output sound decent. We already know that MediaTek are lagging behind in Android 10, with no MiraVision or proper BesLoudness. So I guess it was done with good intention.

0

threads

15

posts

138

credits

Senior Member

Rank: 2

credits
138
Post time 2019-12-31 21:06:32 | Show all posts
Edited by Daguiarmx at 2019-12-31 21:08  
datboyolly replied at 2019-12-31 08:13
Your 3.5mm headphone jack problem is caused by an equalizer app. The problem is even persistent aft ...

Hi there! Thanks I will try fo fix it. For those who have issues with the sound being too loud in lower volumes, there is an easy fix adjusting the values in engineer mode, I guess someone screw the values, but it does work properly once you put 88 (or whatever value you feel comfortable with) and it takes five minutes.cAnd for the framerate in video recording, since the F2 supports Camera2API,I  installed Open Camera and selected the Camera2API and more or less work.

0

threads

21

posts

136

credits

Senior Member

Rank: 2

credits
136
Post time 2019-12-31 23:18:30 | Show all posts
Daguiarmx replied at 2019-12-31 21:06
Edited by Daguiarmx at 2019-12-31 21:08  

The video recording framerate from the main camera app is actually good and consistent. If you're seeing dropped frames during playback, that's a video decoder issue. Upload the video file to a different device and you'll see that it has been recorded perfectly and will play smoothly.

0

threads

21

posts

136

credits

Senior Member

Rank: 2

credits
136
Post time 2019-12-31 23:54:05 | Show all posts
Unbelievable.

Do not enable Duraspeed. It stops MusicFX from starting automatically, and after two restarts, stops the headphone jack from working.
This software fking sucks Umidigi/Droi. I KNEW when you announced Android 10 so soon after release that it would be buggy. And let's not bulls- the customers, the only reason this device was shipped so late was buggy OS. We can even see from the demo videos released AFTER the official shipping date, that the OS wasn't optimised, with the battery and clock icons hidden behind the cutout and camera punchole.

I'm super annoyed.

0

threads

15

posts

138

credits

Senior Member

Rank: 2

credits
138
Post time 2020-1-1 07:19:24 | Show all posts
Edited by Daguiarmx at 2020-1-1 07:21  

I tried all the stuff mentioned here, don't know which one worked but now I have audio through the 3.5mm, bad quality as you said but works, thank you guys!. Video recording framerate works as you said, in a different app other than the gallery app I use thank you again!

0

threads

14

posts

92

credits

Senior Member

Rank: 2

credits
92
Post time 2020-1-1 10:53:33 | Show all posts
Daguiarmx replied at 2019-12-31 21:06
Edited by Daguiarmx at 2019-12-31 21:08  

Cool, I found the setting in the engineer menu.
For some reason "music" was set to 136 for the first level, while everything else has it at 88. I set it to ~70 to start and its much better now.

Comments

can you tell where to go in engineering mode?  Post time 2020-1-4 03:07

0

threads

7

posts

37

credits

New Member

Rank: 1

credits
37
Post time 2020-1-3 03:43:37 | Show all posts
Has anyone had any success in rooting this device?

0

threads

15

posts

138

credits

Senior Member

Rank: 2

credits
138
Post time 2020-1-4 03:13:30 | Show all posts
Nutype replied at 2020-1-1 10:53
Cool, I found the setting in the engineer menu.
For some reason "music" was set to 136 for the fir ...

Dial this *#*3646633#*#*, then look for the audio, all the settings are at 88 for the level 1 but music, fix that and you should have a much better audio experience
12345678Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list