UMIDIGI F1, F1 Play and S3 Pro: Repair IMEIs, MEID and Google certificate

bencebacsi Post time 2020-1-20 20:18:47 | Show all posts   [Copy link]
76 16438
Author: bencebacsi

UMIDIGI F1, F1 Play and S3 Pro: Repair IMEIs, MEID and Google certificate

  [Copy link]

0

threads

7

posts

34

credits

New Member

Rank: 1

credits
34
Post time 2019-10-20 02:43:50 | Show all posts
heelpppp plzzz helpppp

0

threads

7

posts

34

credits

New Member

Rank: 1

credits
34
Post time 2019-10-20 03:10:45 | Show all posts
note : i installed  the rom of 30/01/2019 BUT THE ERROR STAY HOW COULD I FIX IT

0

threads

9

posts

118

credits

Senior Member

Rank: 2

credits
118
Post time 2019-10-20 05:46:42 From the mobile phone | Show all posts
DANKE DANKE DANE`KE, hat wunderbar funktioniert ;) nach 3 fails hab ich die 2 dateien eingefügt und danach PASS!

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2019-10-26 05:45:31 | Show all posts
Thank you this worked for me but the red letters are still on my screen. How do i remove them?

0

threads

7

posts

34

credits

New Member

Rank: 1

credits
34
Post time 2019-10-30 22:44:39 | Show all posts
Ronny.Ernst replied at 2019-10-20 05:46
DANKE DANKE DANE`KE, hat wunderbar funktioniert ;) nach 3 fails hab ich die 2 dateien eingefügt und ...

Wie hast du es geschafft?

0

threads

1

posts

6

credits

New Member

Rank: 1

credits
6
Post time 2019-11-8 22:47:36 | Show all posts
NON_EAA S3 Pro fixed      TEE and Google red text warnings gone.

If your like me the red text has been very very annoying. I was actually looking to see about buying another phone on the sale 11.11.

I kept using the special SN Writer and kept geting the error "TEE PL Failed with -19" no matter what verision I tired. I even tried using SPFT to download the TEE.img from different roms no success. (mentioned in another thread to make a difference)

My solution came by accident; I used SPFT to flash the EAA_20190708 version onto my S3. Im in the US so I am aware that this is not my ROM. Once successful I used the special SN writer for EAA_S3pro and selected the files for MD and AP. Only selected wifi in config with autogen option. (Did not bother with IMEI's as it has been failing for me for 3 weeks). and I finally got the successful/pass notification on SN Writer.

Booted the phone and immediately noticed no more red TEE and Google....YAY!!!!!!!!!!!
used SN writer again to restore IMEI's and MEID (plenty examples of how to do that if you haven't done that already).  But this time on SN writer under Options uncheck TEE support.

By now you should be familiar enough to go ahead and reflash your phone with the proper latest ROM for your region.

Best of luck everyone. Im very happy with this phone, looking to buy another phone because of this i was disappointed to see that without paying more than i did for this phone this is still a great deal. The new F2 is basically the same phone with 3 more cameras. Hopefully the S4 pro improves on that with the addition of an AMOLED screen.

0

threads

3

posts

18

credits

New Member

Rank: 1

credits
18
Post time 2020-1-8 22:43:53 | Show all posts
Edited by basketmind at 2020-1-8 23:03  

THANK YOU for this thread.
I tried it about ten times and it didn't work.
Always got this annoying "TEE PL failed with -19"-message (like others here too). Don't know what this means. But then I looked for another SN-Writer-version and so I installed the latest one (v1.1916.00) and SURPRISE...suddenly it worked and I could read "PASS", yeah.
Now I can see my real IMEI again on my phone but the red annoying Tee and Google text is still on my screen.
Asking myself if it's due to missing one number in my MEID (it just has 14 instead of 15 numbers because you just can insert 14 with SN-Writer).

So next step: Get rid off this horrible big letters and don't stop trying...
Wish me luck! ;)

0

threads

3

posts

16

credits

New Member

Rank: 1

credits
16
Post time 2020-1-10 05:02:22 | Show all posts
Edited by xxlren at 2020-1-10 06:18  

S3 Pro Non-EU
Windows 10


I'm in the same position, with the TEE PL failed -19 message. I have tried many different versions of SN Write Tool and also flashed various ROMs, including the Euro ROM previously mentioned. My phone has been like this since October and I feel my options have been exhausted. Thanks to everyone for the information they've provided

I've also tried connecting the phone through Maui Meta Version 10 software. It will always fail at "Connect to MD" step.

I've tried using different USB ports, USB data cables. Re-locked the OEM bootloader.

Thread History:

02 Mar 2019 - Bencebacsi posts Guide

03 Mar 2019 - Veiran has success with Bencebacsi method

22 Apr 2019 - Diust [F1] gets unspecified Error, but succeeds by rolling back ROM to 2019 01 30

02 May 2019 - Kolupalkin [S3 Pro] gets TEE PL Failed with -19 Error

09 May 2019 - Faysoft [F1] gets Tee PL Failed with -23 Error

17 May 2019 - Bayker [F1 Play] gets TEE PL Failed with -19 Error

31 May 2019 - Chrismelb [F1 Play] gets TEE PL Failed with -23 Error

24 Jun 2019 - Darkstaring [F1] has success with Bencebacsi method

20 Sep 2019 - Marce95 gets TEE PL Failed -19 Error

28 Sep 2019 - Riros has success with Bencebacsi method

16 Oct 2019 - Avestouh [F1] gets TEE PL Failed with -19 Error

26 Oct 2019 - Crit has success with Bencebacsi method

08 Nov 2019 - Rwmegacool [S3 Pro] gets TEE PL Failed with -19 Error. Later has success by reverting to 08 Jul EU ROM.

08 Jan 2020 - Basketmind has success by using the latest version of SN Writer (1.1916).



0

threads

3

posts

18

credits

New Member

Rank: 1

credits
18
Post time 2020-1-10 19:15:24 | Show all posts
Edited by basketmind at 2020-1-10 19:30  

Honestly with SN Writer v1.1916 I just were successful in restoring my IMEI and MEID but the 'red text problem' still exists.

Would be a big help if Bencebacsi could tell us what this "TEE PL Failed -19 Error" is about.

My smartphone:     Umidigi F1 Play
ROM:                    2019090318_g38v71c2k_kw_f1_play_eea
SN-Writer:             SNWrier_1828-4.0.0-vturkey_F1_EEA


It's always the same procedure:

I start SN Writer turkey version (in my case the european one) and do the settings like recommended.

starting program with recommended settings

starting program with recommended settings

Then I enter my correct IMEI 1+2 and MEID.

entering correct numbers

entering correct numbers


I click ok. 'Start searching preloader com port and handshake...' appears on my screen.

after clicking ok

after clicking ok

Now I connect my powered off phone via usb to the PC. I hear the 'connection noise' and after about one second the 'disconnection noise'.
The program now says 'Start searching kernel com port and handshake...'

waiting...

waiting...

After about 5 seconds I again hear the 'connection noise'
(now sometimes the phone switches to Meta-Mode, sometimes it doesn't...nevertheless, the following result is the same)
The program steps to 'Searching kernel com port and handshake OK.'

waiting...

waiting...

And after 5-10 seconds I get the FAIL message and always 'TEE PL Failed -19 Error'.

...bad result!

...bad result!

All in all I tried it more than 50 times, used different USB-ports and all officially existing F1-Play-ROMs.
Unfortunately with no satisfying results.

Would appreciate it if Bencebacsi or someone else could find a solution.
As a little thank you I include you in my prayers before I go to bed. ;-)

Thanks in advance!

0

threads

5

posts

28

credits

New Member

Rank: 1

credits
28
Post time 2020-1-20 20:18:47 | Show all posts
HI how do I get rid of the tee and google red certificate information on  my umidigi s3 pro
12345678Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list