UMIDIGI S3 Pro

Rado Post time 2020-5-7 19:34:54 | Show all posts   [Copy link]
144 14705
Author: Rado

UMIDIGI S3 Pro

  [Copy link]

0

threads

18

posts

86

credits

Senior Member

Rank: 2

credits
86
Post time 2019-10-31 10:49:22 | Show all posts
No updates since August? Is that right?

Still having Bluetooth issues (minor) and fingerpint issues (major)

The fingerprint reader does not play well with applications. All of them crash on setting fingerprint security. Worked on the updated before last, stopped working. (Yes, I have done factory reset and start from clean. No joy.)

0

threads

5

posts

50

credits

Senior Member

Rank: 2

credits
50
Post time 2019-11-9 07:21:54 | Show all posts
thesamim replied at 2019-10-31 10:49
No updates since August? Is that right?

Still having Bluetooth issues (minor) and fingerpint issues ...

The same here - Disappointed that the fingerprint doesn't work in all applications and when it does it is intermittent.  Also no Android security updates since August too

0

threads

18

posts

86

credits

Senior Member

Rank: 2

credits
86
Post time 2019-11-28 05:35:29 | Show all posts
happyman replied at 2019-11-9 07:21
The same here - Disappointed that the fingerprint doesn't work in all applications and when it doe ...

After getting really frustrated with Fingerprint interaction, I reached out to tech support. They recommended reflashing following the instructions here:
https://community.umidigi.com/fo ... &extra=page%3D1

Used the SP Flash Tool, following instructions very carefully. (Used the "Firmware Upgrade" option.)

That fixed that issue! I was surprised, frankly.

NOTE: This WILL wipe out all user data.

Recommend opening a ticket with support first so they can track how many times this happens. Also: there's all kinds of dire warnings about following the procedure voiding your warranty unless instructed to do the procedure as instructed by support personnel...

Not positive (it's only been a couple of days) but I think this fixed the Bluetooth issues as well.

0

threads

5

posts

50

credits

Senior Member

Rank: 2

credits
50
Post time 2019-11-28 21:26:26 | Show all posts
You are flashing with the same version you already had installed though ?

Does anyone know if the Google account backups back up everything on the phone? - Does it restore everything back afterwards ?

Thanks

0

threads

1

posts

8

credits

New Member

Rank: 1

credits
8
Post time 2019-12-4 01:48:19 | Show all posts
happyman replied at 2019-11-28 21:26
You are flashing with the same version you already had installed though ?

Does anyone know if the G ...

Yes it does.
I had to reflash the firmware a few days ago, and it worked.

0

threads

18

posts

86

credits

Senior Member

Rank: 2

credits
86
Post time 2019-12-6 00:26:08 | Show all posts
Edited by thesamim at 2019-12-6 00:27  
happyman replied at 2019-11-28 21:26
You are flashing with the same version you already had installed though ?

Does anyone know if the G ...

Yes.

Yes the google back up works if you've set it up correctly. Keep in mind that it works for app recovery. If you're apps are not saving to the cloud, you'll have to deal with each App's data....

Note: SMS is not backed up. If it's important to you, you might want to back up with SMSBackup.

0

threads

18

posts

86

credits

Senior Member

Rank: 2

credits
86
Post time 2019-12-24 07:00:58 | Show all posts
mrouillard replied at 2019-12-4 01:48
Yes it does.
I had to reflash the firmware a few days ago, and it worked.

In case anyone is watching this for the fingerprint issue:
Reflash of latest available version only fixed the issue for about three weeks. Then it reverted to not working. No new software was installed.

Reached out to support. They a) claim to have never heard about his issue, b) have not gotten back to me after sending supporting information and bug reports (with pointers in the bug report to where the issue occurs.)

If you are having the same issue, please open a support ticket so we can get documentation that this is not an isolated case.

0

threads

2

posts

8

credits

New Member

Rank: 1

credits
8
Post time 2020-2-19 05:38:17 | Show all posts
Hi all,

Hopefully, I won t mess this up and I ll write this in the right place.  I would appreciate if you could help me with the following or at least just dropping a few hint where to start. I bought s3 pro in UK in june 2019. No problem at all with the phone strong as a bull. Today morning I put it on charge /was charged arond 70%/. So as soon as I put it on just gone. black. died. since then nothing. Repair shop says there is no current going through the battery or phone. Have I fried it? If yes, do you have any phone number or contact or address where I can send it to ? Obviously I love to get back my data from the phone. Has anyone done this before sending it away? Heeeelp plz. Thank you.

0

threads

5

posts

18

credits

New Member

Rank: 1

credits
18
Post time 2020-3-17 20:34:58 | Show all posts
Same problem, zero support. Go buy a better brand next time.

0

threads

1

posts

12

credits

New Member

Rank: 1

credits
12
Post time 2020-5-7 19:34:54 | Show all posts
Zero support and no answer or nobody want to say something for a month???no updates from Umidigi,no wifi call on S3 working,so i dont think so its a good brand to buy...Bence bácsi pár hónapja jelöltelek,de semmi.Gondoltam hátha tudnék kérdezni,mivel admin vagy.Jelkezz
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list