Z2 Pro dual band wifi need a fix - a reminder

saikee Post time 2018-9-23 12:58:41 | Show all posts [Copy link]
47 2609
View: 2609|Reply: 47

Z2 Pro dual band wifi need a fix - a reminder

[Copy link]

3

threads

119

posts

392

credits

Platinum Member

Rank: 3Rank: 3

credits
392
Post time 2018-9-20 18:28:41 | Show all posts |Read mode
A forum member has reported that his new z2 pro could log on to the 5Ghz but not 2.4Ghz.  This prompted me to check mine.  My Z2 pro has exactly the opposite.  It can do 2.4Ghz but not 5Ghz.

As I have a s2 Pro too so I tested the dual bands with it in the same condition and the s2 can switch between the two.  Thus I am convinced there is a problem in the dual band wifi in the Z2 Pro.

Basically the z2 pro can detect the 5Ghz in my case but after entering the password it does not make the connection.  Repeated attempts require the password again but fail every time, even if I disabled the 2.4Ghz forcing the Z2 pro to use the 5Ghz channel.  

Can I remind UMI include a fix for it in the future updates?

Apart from not able to use pin and pattern securities my Z2 pro has been operating normally using password as security.  

3

threads

119

posts

392

credits

Platinum Member

Rank: 3Rank: 3

credits
392
 Author| Post time 2018-9-23 18:54:42 | Show all posts
Edited by saikee at 2018-9-23 18:57 \n\n Edited by saikee at 2018-9-23 18:57 \n\nhemereke,

I think my steps to get dual band working were:-

(1) forget the working band so the phone has no Internet
(2) Add the band that Z2 pro refuse to connect.
(3) Reboot phone
(4) The band previously refuse to connect suddenly connects
(5) Add the forgotten band
(6) Switch bands to ensure both operational.
(7) Tap the working band to find out its link speed.

ac wifi also requires the router having this feature.  If the router does not has ac protocol you may be flogging a dead horse to get 5Ghz working faster than 2.4Ghz.

I use a British Telecom  (BT) Home hub that does not tell me the frequencies except Mode 1, 2 & 3.  The hub defaults to Mode 1 in 5Ghz and is the only mode compatible with ac wifi apparently.

1

threads

47

posts

270

credits

Platinum Member

Rank: 3Rank: 3

credits
270
Post time 2018-9-21 01:36:45 From the mobile phone | Show all posts
Had the same problem, entered my password and nothing, couldn't connect to the 5ghz channel. But after I connected to the 2.4Ghz channel and left my house and came back after a while I noticed it connected to the 5Ghz automatically.

3

threads

119

posts

392

credits

Platinum Member

Rank: 3Rank: 3

credits
392
 Author| Post time 2018-9-21 08:48:31 | Show all posts
Mine is consistently refusing to connect to 5Ghz and can't remember the password.

Under the same condition in the house my older s2 pro can do both bands so it is clearly an issue with Z2 pro.

0

threads

14

posts

63

credits

Senior Member

Rank: 2

credits
63
Post time 2018-9-21 11:47:23 From the mobile phone | Show all posts
My z2 pro detects both 2.4 and 5, it appears in the wifi list, but only 5 ghz accepts passwords.2.4 GHz can not be connected. I thought this was a specification....Is this also a bug?

1

threads

47

posts

270

credits

Platinum Member

Rank: 3Rank: 3

credits
270
Post time 2018-9-21 13:01:41 From the mobile phone | Show all posts
After the update to the latest version the phone can't connect to the 5Ghz network anymore.

0

threads

31

posts

281

credits

Platinum Member

Rank: 3Rank: 3

credits
281
Post time 2018-9-21 14:04:19 | Show all posts
I did have this problem to, but after doing proces (Login + PW) can switch without problems 24-5 Ghz.

3

threads

119

posts

392

credits

Platinum Member

Rank: 3Rank: 3

credits
392
 Author| Post time 2018-9-21 21:29:19 | Show all posts
I like to report that the first wifi update, available from today from 20180823 to 20180920, has cured my dual band problem apparently, in addition to resolving the pin and pattern security problems.  I can freely select either band to connect to although a reboot may be required if it still remains stubborn.

The camera seems to be able to focus closer too.

0

threads

14

posts

63

credits

Senior Member

Rank: 2

credits
63
Post time 2018-9-22 17:42:36 From the mobile phone | Show all posts
I updated the latest, but after all I could not connect to 2.4 gz.

3

threads

119

posts

392

credits

Platinum Member

Rank: 3Rank: 3

credits
392
 Author| Post time 2018-9-22 17:59:01 | Show all posts
hemereke,

Try forget the 5Ghz thereby forcing z2 pro to use 2.4Ghz band and reboot the phone to see if the problem persist.

Z2 pro may still have a stability problem with dual band.

0

threads

14

posts

63

credits

Senior Member

Rank: 2

credits
63
Post time 2018-9-23 12:58:41 | Show all posts
I tried it, but I could not connect to 2.4 GHz.
The procedure I tried is below.

1. Turn off z2 pro Wi-Fi setting.
2. Delete all Wi-Fi settings.
3.Enter the password for 3.2.4 GHz SSID
-> I can not connect...
4.Enter password for 4.5 GHz SSID
-> I got connected!

Ummm ....
12345Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list