Root your UMIDIGI with Magisk Manager

bencebacsi Post time 2019-8-23 09:19:05 | Show all posts   [Copy link]
61 50908
Author: bencebacsi

Root your UMIDIGI with Magisk Manager

  [Copy link]

0

threads

1

posts

74

credits

Non- Vertification

credits
74
Post time 2019-5-11 08:57:07 From the mobile phone | Show all posts
I get an error msg https://i.vgy.me/N2yqAs.png

Smart Phone Flash Tool
ERROR : STATUS_SEC_INSUFFICIENT_BUFFER (0xC002004B)

[HINT]:
Verified boot is enabled.
Please download signed image(boot-verified.img) or disable verified boot.

0

threads

63

posts

347

credits

Platinum Member

Rank: 3Rank: 3

credits
347
Post time 2019-6-18 22:30:56 | Show all posts
I can't get past step 13, because SP Flash Tool (v 5.1824 and .1904) says that it cannot continue because verified boot is enabled.

What I tried was removing the screen lock with pattern and fingerprint, which also would protect bootup, but that didn't help.

How do I proceed?

Thanks in advance for any tips.

Sascha

0

threads

63

posts

347

credits

Platinum Member

Rank: 3Rank: 3

credits
347
Post time 2019-6-19 20:46:26 | Show all posts
Today I used SPFT v5.1916 and this managed to flash the patched boot.img from Magisk Manager 7.3.1.

However, with this img the phone won't boot up. It says:
"Red State
Your device has failed the verification and may not work properly.
Please download boot image with correct signature or disable verified boot.
Your device will reboot in 5 seconds..."
and it keeps rebooting.

What has gone wrong now?

0

threads

63

posts

347

credits

Platinum Member

Rank: 3Rank: 3

credits
347
Post time 2019-6-20 21:13:10 | Show all posts
Edited by InTheY2K at 2019-6-23 00:34  

GOT IT!

OEM unlocking in the developer settings was not enough. What was missing in my case was the step executing the command "fastboot flashing unlock". After completing that and flashing the patched boot image, Magisik is now working! YAY! :-D

Might be a stupid question: But can I now lock the bootloader again without resetting the phone to factory state? And will I still have root then? It would just be nice to get rid of the warning message during bootup.

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2019-6-30 19:24:15 | Show all posts
dadainnyc replied at 2019-2-8 01:44
this method doesn't work for f1 + magisk v18...after flash patch boot.img magisk manager still says  ...

if you have an sd card just move magisk manager onto the internal storage, that worked for me on my umidigi a1 pro.

0

threads

4

posts

38

credits

New Member

Rank: 1

credits
38
Post time 2019-7-18 01:57:19 | Show all posts
InTheY2K replied at 2019-6-20 21:13
Edited by InTheY2K at 2019-6-23 00:34  

GOT IT!

I am having a same problem. How did you enter in fastboot mode? When "adb reboot bootloader", phone shows only "FASTBOOT mode..." in bottom left corner, very small font nothing else.
When typed fastboot flashing unlock, it waits forever, device not found. Please help

0

threads

4

posts

38

credits

New Member

Rank: 1

credits
38
Post time 2019-7-18 22:36:36 | Show all posts
tutaqq replied at 2019-7-18 01:57
I am having a same problem. How did you enter in fastboot mode? When "adb reboot bootloader", phon ...

OK looks like I had an older version of adb and fastboot, after updating to latest managed to unlock bootloader and root my A5 pro. There is 'orange alert' but who cares. Would love to see TWRP for this phone. Thanks

Comments

Glad you got it sorted! (Y)  Post time 2019-7-22 16:58

0

threads

116

posts

448

credits

Platinum Member

Rank: 3Rank: 3

credits
448
Post time 2019-8-17 01:26:22 | Show all posts
is this confirmed working with A5_Pro? i want to use some root applications for my A5_Pro to diagnose my screen, as i am getting a single pixel width green line down the left side of the display.

0

threads

116

posts

448

credits

Platinum Member

Rank: 3Rank: 3

credits
448
Post time 2019-8-23 09:00:47 | Show all posts
so those with the A5_Pro: this does not work.. boot loop after flashing the patched boot.img... probably not going to fiddle with this one. cheers

0

threads

116

posts

448

credits

Platinum Member

Rank: 3Rank: 3

credits
448
Post time 2019-8-23 09:19:05 | Show all posts
tutaqq replied at 2019-7-18 22:36
OK looks like I had an older version of adb and fastboot, after updating to latest managed to unlo ...

which version of TWRP are you using? i can get the boot loader unlocked - the 'fastboot oem unlock' command doesn't seem to work but 'fastboot flashing unlock' does allow me to unlock the boot loader. anyway - after i flash recovery.img through fastboot, i do a manual reboot and get into recovery, but when it boots into TWRP i get a black screen with a green line across the top of the phone (left to right), then it reboots and then reverts the recovery back to stock... i tried the Magisk boot patch method on the forum post - step for step but that fails as well. after i flash the boot.img through the SP tool, i get a boot loop - loads the first boot image and then reboots. i'm on just a straight up flashed 1.4 firmware for the A5 Pro - after trying the other methods of root, i gave up and went back to complete stock. cheers!
123456Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list