UMIDIGI Crystal V1.1_20170929 ROM - SPFT + OTA release

bencebacsi Post time 2017-10-27 01:11:53 | Show all posts [Copy link]
51 8732
Author: bencebacsi

UMIDIGI Crystal V1.1_20170929 ROM - SPFT + OTA release

[Copy link]

0

threads

12

posts

50

credits

Senior Member

Rank: 2

credits
50
Post time 2017-10-20 23:52:09 | Show all posts
Edited by bart877ie at 2017-10-21 00:14 \n\n Edited by bart877ie at 2017-10-20 23:53 \n\nGood Afternoon, I think I have the solution for GPS FIX, so far it works great, fix is achieved very fast. Can somebody follow my steps and let me know, please. There is link to video showing my device working fine.
1) Enter SERVICE MENU #*#3646633#*#
2) go to Location TAB (on the TOP)3) Select Location Based Services


0

threads

12

posts

50

credits

Senior Member

Rank: 2

credits
50
Post time 2017-10-20 23:54:14 | Show all posts
4) First Grey Button is GPS(OFF) flick to ON - below that you will see Satelite status updates
5) Change GPS MODE to FULL START
6) You should get Prompt from LocationEM2 asking for permissions - grant ALL
7) Go to last Tab - RAW DATA and flick navigation to ON and measurement to ON
- Your GPS should work.

Comments

Thank you for sharing this, is working! Please post this method in my thread: Tips and tricks-How to?  Post time 2017-11-13 00:01

0

threads

12

posts

50

credits

Senior Member

Rank: 2

credits
50
Post time 2017-10-20 23:55:21 | Show all posts
I have performed this in the morning, the device was switched on and off multiple times and I have no longer issue with GPS.
When outside lock is very quick and is constant, I have my OnePlus5 for comparison and there is no difference.
I have noticed that when I log back to service menu all settings were reverted, but GPS is still working.
NOTE: I am not taking any responsibility for your device if it stops working.
Software version is BUILD NUMBER UMIDIGI_CRYSTAL_V1.1_20170929 Model is 4gb/64GB
https://photos.app.goo.gl/aEfOqdwpdyH7AdNa2 - here is video showing device in working order

0

threads

14

posts

108

credits

Senior Member

Rank: 2

credits
108
Post time 2017-10-21 15:39:42 | Show all posts
lucaspeed replied at 2017-10-14 04:31
I tried again installing the update today on my two Crystals 4 Gb. This is all I get. Anyone can hel ...

I'm having this error too, but I'm pretty much sure it's because I enabled root in Developer options.
Many phones check for root, and don't allow updating if the system has been modified by any means.
I had no problem updating to 20170903 rom, but the newest (after root) gives me Error message.
Try disabling root, and/or do a factory reset, then try again. Should be good after that.

0

threads

16

posts

136

credits

Senior Member

Rank: 2

credits
136
Post time 2017-10-21 20:23:41 | Show all posts
bart877ie, I tried your steps but I don't get the prompt you mention at (6) - is your phone rooted?  

0

threads

12

posts

50

credits

Senior Member

Rank: 2

credits
50
Post time 2017-10-22 07:35:41 | Show all posts
No, it is stock. No software alterations were made. GPS is still working without issues. It is almost impossible to get lock/fix inside the building, but outside it works very well. I was driving and cycling and everything is as it should be.

0

threads

12

posts

50

credits

Senior Member

Rank: 2

credits
50
Post time 2017-10-22 07:37:33 | Show all posts
Is your device still unable to fix/lock to GPS? I have done factory reset today and GPS was unable to get fix. But when I recreated those steps it started to work.

1

threads

49

posts

340

credits

Platinum Member

Rank: 3Rank: 3

credits
340
Post time 2017-10-23 05:25:48 | Show all posts
Edited by Axelro at 2017-10-23 15:44 \n\n@bart877ie. Happy that you share with us this procedure. One quick question: Your device is roote? Thank you!L.E. I saw that you answer allready in previous post. Is Stock. Thank you!

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2017-10-25 02:17:35 | Show all posts
Hi everyone, just received my Crystal 4GB and to my sad surprise the GSM module (or antenna) is not working correctly, so the can't log to network. It logs occasionally for couple seconds to drop the connection again. One way or another, I didn't manage to make any single call. All other function seem to be working well. I have updated phone to the latest firmware and checked several sim cards that were working well on other phones placed next to Crystal. Any suggestion on what to do would be appreciated.

0

threads

9

posts

54

credits

Senior Member

Rank: 2

credits
54
Post time 2017-10-27 01:11:53 | Show all posts
Burs replied at 2017-10-21 15:39
I'm having this error too, but I'm pretty much sure it's because I enabled root in Developer optio ...

I have disabled root but I still have the same error, I tried to update using recovery but this is what I receive, I absolutely cannot do a factory reset and reinstall everything on two phones, this is madness.

IMAGE 2017-10-26 19:08:59.jpg
123456Next
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list