UMIDIGI Z1 Pro V1.1_20170804 ROM - SPFT + OTA release

bencebacsi Post time 2018-2-16 01:23:57 | Show all posts [Copy link]
144 12830
Author: bencebacsi

UMIDIGI Z1 Pro V1.1_20170804 ROM - SPFT + OTA release

[Copy link]
 Author| Post time 2017-9-11 09:28:24 | Show all posts
digiNZM replied at 2017-9-10 17:31
Any chance for beta-testing the Z1 Pro UmiOS? ;)

It's done already, so it's too late for beta testing. I'm waiting for the info about the release date.
EDIT: It's not done yet but a beta testing program will open today.
 Author| Post time 2017-9-11 10:00:54 | Show all posts
flledo replied at 2017-9-11 07:57
Edited by flledo at 2017-9-11 08:06 \n\nIf someone with the UMIDIGI Z1 PRO wants to do it root with ...

Magisk can root Z1 Pro but it's better to always patch the boot.img present in your current system, don't use a different version, that doesn't match your system. The installation is very simple, so it's better to follow the instructions provided here:  https://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445
 Author| Post time 2017-9-11 12:47:24 | Show all posts
V1.1_20170907 update is available now via OTA. Please check it in Settings --> About phone --> Wireless update.
I'm going to share bothe the flash tool release and the OTA update file here in the ROM section later today.

0

threads

28

posts

271

credits

Platinum Member

Rank: 3Rank: 3

credits
271
Post time 2017-9-12 02:38:49 | Show all posts
flledo replied at 2017-9-11 07:57
Edited by flledo at 2017-9-11 08:06 \n\nIf someone with the UMIDIGI Z1 PRO wants to do it root with ...

Do the Magisk Modules work for you? I still get the "permission denied" error (loop0 mount) in magisk-log and i can't install any modules.
You did something to patch this?

1

threads

15

posts

79

credits

Senior Member

Rank: 2

credits
79
Post time 2017-9-12 04:12:35 | Show all posts
Edited by flledo at 2017-9-12 08:46 \n\n
Do the Magisk Modules work for you? I still get the "permission denied" error (loop0 mount) in mag ...

It is necessary uninstall any previous root and if you had already installed mgisk, uninstall it (there is a desistalador that cleans it all).
Once clean, copy boot.img into the memory of the phone install magisk manager apk, open it and click on install.
To me the first time gave me a problm but I changed the boot.img to a folder that is called [Internal Storage]/MagiskManager that the had created it the apk and I returned to execute the installation.
At the end had put in the of magisk folder the file "patched_boot.img."
Now copy that file in the PC and flashing with SP Flashtools, reboot the mobile .... you should be already root.

0

threads

28

posts

271

credits

Platinum Member

Rank: 3Rank: 3

credits
271
Post time 2017-9-12 12:32:05 | Show all posts
Edited by digiNZM at 2017-9-12 14:09 \n\n
flledo replied at 2017-9-12 04:12
Edited by flledo at 2017-9-12 08:46 \n\nDo the Magisk Modules work for you? I still get the "permis ...

Ok, i know that rooting is working fine, been doing this since Magisk 13.6 beta.
The only thing that won't work for me are MagiskHide and MagiskModules.
You can see this in the Magisk-Log.

Edit: Magisk Modules & Magisk Hide not working - preferably set the "MinimalMode" in the Settings to save Ressources
Root works as expected though (since Magisk 13.6beta).

1

threads

15

posts

79

credits

Senior Member

Rank: 2

credits
79
Post time 2017-9-13 00:30:34 | Show all posts
For me, the only interest I have is being able to be root and have access to everything.
I'd rather install the original rom than make backups.
Being root you can make a backup of all the applications, of files like wpa_supplicant.conf and others of interesting.
With respect to partitions like nvram and others that does not bring the official ROM, with FlashTools and a few simple ADB commands can be easily extracted .
If someone needs help or advice, I will gladly make the contribution.
(forgive my pesimo ingles). A greeting.

1

threads

15

posts

79

credits

Senior Member

Rank: 2

credits
79
Post time 2017-9-13 05:51:24 | Show all posts
Today I installed the 20170907 new ROM. I have tried it by OTA but it has given me a bug. In the end I did it with FlashTools but I did not include either the bootloader or the userdata. Result, faster loading and only updates the system, data, applications, and settings do not touch them. (Only one exception, if you has put something in the system, that disappears as the root. After I installing MAGISK, I processed the boot.ini, reboot and everything working perfectly and with root installated.
Everything a success

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2017-9-26 11:07:25 | Show all posts
bencebacsi replied at 2017-8-11 09:10
I have reported this issue to the developers (an old system webview app is installed and active in  ...

Hi friend.
Thank you so much. It really worked. now Ijust wnat to find solution for GMail crash an others. OMG so many bugs.

0

threads

12

posts

218

credits

Platinum Member

Rank: 3Rank: 3

credits
218
Post time 2018-2-16 01:23:57 | Show all posts
Buenas..
No tengo mucha idea de esto pero.. me compre el movil y venia con umi 2.0... se puede instalar esta rom con spft?
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list