[Closed Cyanogen Port Thread.] Looking for help with the Umi eMax!

J.Naw Post time 2015-10-13 10:08:10 | Show all posts [Copy link]
48 7197
Author: J.Naw

[Closed Cyanogen Port Thread.] Looking for help with the Umi eMax!

[Copy link]

0

threads

47

posts

323

credits

Platinum Member

Rank: 3Rank: 3

credits
323

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-10-13 06:58:34 | Show all posts
Edited by LoLaTiOn at 2015-10-13 07:06 \n\n
oups edite
flash tool link flash here for android 5 > http://www.mediafire.com/downloa ... .0_FlashtoolROM.zip
look also here > http://community.umidigi.com/for ... 45&fromuid=1528

7

threads

66

posts

276

credits

Platinum Member

Rank: 3Rank: 3

credits
276
 Author| Post time 2015-10-13 07:02:25 | Show all posts
LoLaTiOn replied at 2015-10-13 06:58
oups edite
flash tool link flash here for android 5 > http://www.mediafire.com/download/su43576c0vo7 ...

Sweet, Will download immediately. I am going to guess you don't know why the mount points are different?

0

threads

47

posts

323

credits

Platinum Member

Rank: 3Rank: 3

credits
323

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-10-13 07:13:31 | Show all posts
not sorry I can not answer you about it the mount point
it is quite different between different device which makes me say that it seems normal
as well as android 4 and 5
can be that you put the focus on a potential problem but I doubt

the current main problem is similarly band related to Rom and boot.img driver

7

threads

66

posts

276

credits

Platinum Member

Rank: 3Rank: 3

credits
276
 Author| Post time 2015-10-13 07:19:46 | Show all posts
LoLaTiOn replied at 2015-10-13 07:13
not sorry I can not answer you about it the mount point
it is quite different between different devi ...

The issue is that the META-INFS for the 4.4.4 Umi Emax COLOROS is pointed at mmcb1k0p6.. Which doesn't make sense.

And yeah, Network problems are an issue, But I gotta be able to install the darn OS first

0

threads

47

posts

323

credits

Platinum Member

Rank: 3Rank: 3

credits
323

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-10-13 07:47:09 | Show all posts
Edited by LoLaTiOn at 2015-10-13 07:48 \n\n
mmcblk0p6 is system block for kitkat and lollipop like ("ext4", "EMMC", "/dev/block/mmcblk0p6", "/system");

no need change this block because you can not produce a flash build for spft !this is only way for start flash

7

threads

66

posts

276

credits

Platinum Member

Rank: 3Rank: 3

credits
276
 Author| Post time 2015-10-13 08:33:42 | Show all posts
Edited by J.Naw at 2015-10-13 08:43 \n\n
  1. root@eMAX:/ # cat /proc/emmc
  2. cat /proc/emmc
  3. partno:    start_sect   nr_sects  partition_name
  4. emmc_p1: 00000400 00001800 "proinfo"
  5. emmc_p2: 00001c00 00002800 "nvram"
  6. emmc_p3: 00004400 00005000 "protect1"
  7. emmc_p4: 00009400 00005000 "protect2"
  8. emmc_p5: 0000e400 00000200 "seccfg"
  9. emmc_p6: 0000e600 00000300 "lk"
  10. emmc_p7: 0000e900 00008000 "boot"
  11. emmc_p8: 00016900 00008000 "recovery"
  12. emmc_p9: 0001e900 00003000 "secro"
  13. emmc_p10: 00021900 00000400 "para"
  14. emmc_p11: 00021d00 00004000 "logo"
  15. emmc_p12: 00025d00 00005000 "expdb"
  16. emmc_p13: 0002ad00 00002800 "tee1"
  17. emmc_p14: 0002d500 00002800 "tee2"
  18. emmc_p15: 0002fd00 00010300 "metadata"
  19. emmc_p16: 00040000 00300000 "system"
  20. emmc_p17: 00340000 00038000 "cache"
  21. emmc_p18: 00378000 01989400 "userdata"
  22. emmc_p19: 01d01400 00015800 "otp"
  23. emmc_p20: 01d16c00 00008000 "flashinfo"
  24. root@eMAX:/ # ^C
  25. C:\Users\White>adb shell
  26. shell@eMAX:/ $ su
  27. su
  28. root@eMAX:/ # busybox ls -QAl --color=never /dev/block/platform/*/by-name
  29. busybox ls -QAl --color=never /dev/block/platform/*/by-name
  30. total 0
  31. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "boot" -> "/dev/block/mmcblk0p7"
  32. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "cache" -> "/dev/block/mmcblk0p17"
  33. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "expdb" -> "/dev/block/mmcblk0p12"
  34. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "flashinfo" -> "/dev/block/mmcblk0p20"
  35. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "lk" -> "/dev/block/mmcblk0p6"
  36. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "logo" -> "/dev/block/mmcblk0p11"
  37. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "metadata" -> "/dev/block/mmcblk0p15"
  38. -rw-r--r--    1 0        0                0 Jan  1  2010 "mobile_info"
  39. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "nvram" -> "/dev/block/mmcblk0p2"
  40. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "otp" -> "/dev/block/mmcblk0p19"
  41. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "para" -> "/dev/block/mmcblk0p10"
  42. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "proinfo" -> "/dev/block/mmcblk0p1"
  43. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "protect1" -> "/dev/block/mmcblk0p3"
  44. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "protect2" -> "/dev/block/mmcblk0p4"
  45. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "recovery" -> "/dev/block/mmcblk0p8"
  46. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "seccfg" -> "/dev/block/mmcblk0p5"
  47. lrwxrwxrwx    1 0        0               20 Jan  1  2010 "secro" -> "/dev/block/mmcblk0p9"
  48. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "system" -> "/dev/block/mmcblk0p16"
  49. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "tee1" -> "/dev/block/mmcblk0p13"
  50. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "tee2" -> "/dev/block/mmcblk0p14"
  51. lrwxrwxrwx    1 0        0               21 Jan  1  2010 "userdata" -> "/dev/block/mmcblk0p18"
Copy the Code
Hmm... I will try the emmc_p6.. But the device says p16... This is bugging me.. I must be wrongly reading how the partitions work then...

EDIT: I am gonna try flashing the ROM without changing/swapping kernels from the COLOROS ROM I have, lets see if thats the cause of the issues.
EDIT2: OH I think I understand.. The SPFT only allows installing the system under p6...?


7

threads

66

posts

276

credits

Platinum Member

Rank: 3Rank: 3

credits
276
 Author| Post time 2015-10-13 08:58:03 | Show all posts
Hmm. I see what you mean.. the cellular network does not connect and the camera is completely missing..

Wouldn't a fix for the camera just be to find an .apk from the M2M and move it over to the eMax?

7

threads

66

posts

276

credits

Platinum Member

Rank: 3Rank: 3

credits
276
 Author| Post time 2015-10-13 10:08:10 | Show all posts
Edited by J.Naw at 2015-10-13 10:14 \n\nOkay, so I've gotten somewhere.. I added some files into /etc/firmware, and replaced 2 files, which has removed the ability to even get into the cellular network settings, so that's a start..?

*sigh* I have no idea from where to go from here. I think i'm just gonna lay back until UMI can fix this issue, then once they officially release 5.1.1, i'll port over cyanogen then. But for now, I'm just gonna use my Note 2. I can easily try any ideas people get, No problem. I just don't got any more..
12345
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list