UMI eMAX Touch screen issue + Ghost touch issue

GDD Post time 2015-9-4 05:25:25 | Show all posts [Copy link]
103 23042
Author: GDD

UMI eMAX Touch screen issue + Ghost touch issue

[Copy link]

0

threads

8

posts

71

credits

Senior Member

Rank: 2

credits
71
Post time 2015-8-16 21:05:55 | Show all posts
Hi everyone,
I too have ghost touches.
Nothing worked to solve it (Factory reset, flash with V05 rom, removing the screen protector)
I still have ghost touches in fixed position on the screen registering when i touch the lower portion of the screen.
Strangly it's not always registering "touch" just showing up.

This seems like incorrectly placed screen+digitizer cable which requires me to disassemble the phone.

Any thoughts ?

0

threads

8

posts

71

credits

Senior Member

Rank: 2

credits
71
Post time 2015-8-17 01:28:17 | Show all posts
Hi, i couldn't find any tutorial for disassembling the phone, tried the most solution suggested here but the disassembling and reassembling the phone.

0

threads

46

posts

325

credits

Platinum Member

Rank: 3Rank: 3

credits
325

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-8-17 02:34:23 | Show all posts
Edited by LoLaTiOn at 2015-8-17 04:58 \n\nHi,

I have this problem only on day after using the car attachment to use the GPS

Checked with AnTuTu for see whats happen
Then I use the touch only a second key ghost on the right center.

I slightly try twisted phone lightly and since nothing.

I wonder if it's not just that it is fragile but I'm not sure.

Warning do not twist your phone ! this is just my feedbadk

0

threads

8

posts

71

credits

Senior Member

Rank: 2

credits
71
Post time 2015-8-17 14:40:56 | Show all posts
It seems "ghost touch" appears at the same location (right center).

3

threads

40

posts

178

credits

Senior Member

Rank: 2

credits
178
Post time 2015-8-18 19:10:59 | Show all posts
My ghost touches too.

0

threads

8

posts

39

credits

New Member

Rank: 1

credits
39
Post time 2015-8-18 23:31:15 | Show all posts
Is there any more from UMI on this ridiculous problem?

Thanks Hally

1

threads

5

posts

34

credits

New Member

Rank: 1

credits
34
Post time 2015-8-24 19:08:58 | Show all posts
I thought my ghost issues had stopped after factory resets/rootjoy flashing, but the issue is back and its so random now, I just dont know what is causing it.

I downloaded a touchscreen test app from play store, if the emax starts the random touches on the screen, I load that app up and then the problem magically stops. I don't know why the app stops the ghost touches but it does.
After a day or two the ghost touches start again, so I load the app up and the ghost touches stop.

If mine stop from using the app called YAMTT (yet another multitouch test) does that means its a firmware/software glitch rather than a hardware issue?

1

threads

5

posts

34

credits

New Member

Rank: 1

credits
34
Post time 2015-8-26 23:00:16 | Show all posts
I did read this thread bencebacsi, but no definite reason for the ghost touch. If it was hardware why isn't it doing it all the time? Why does the ghost touch totally vanish when I run the screen touch app? Ill have ghost touches ill open the app, the app doesn't register ghost touches, I exit the app and magically the ghost touch issue has gone. So how can this be a hardware issue for me?

0

threads

1

posts

11

credits

New Member

Rank: 1

credits
11
Post time 2015-8-27 04:12:17 | Show all posts
Static charge!

It is not only the problem of Emax - static charge is troublesome for phones from many manufactuers (the main market players as well!).

I wiped the screen with cloth (actually I used my trousers) and voila - Yet Another Multi Touch Test does not show *random* points when the screen is pressed. Later I rubbed my hair and t-shirt with the phone - and guess what happened? YAMMT started showing random points when I tapped the screen (actually those points show up in more-or-less the same area). It doesn't always work like this, but there are lots of discussions about the problem around the net.

Just check:
http://www.mudeth.org/blog/2011/ ... ouchscreens-static/
...or...
http://en.miui.com/thread-22351-5-1.html

0

threads

25

posts

147

credits

Senior Member

Rank: 2

credits
147

Warmest Heart UMIDIGIerUMIDIGIer

Post time 2015-9-4 05:25:25 | Show all posts
Has anyone sorted a fix for this then, read through the possibilities of it being static, hardware or software but can anyone shed anymore light on actual methods that fix it?
It comes and go's for me (ie weeks its OK then all of a sudden it appears for an hour or so....... arggggg)

  
You have to log in before you can reply Login | WELCOME TO UMIDIGI COMMUNITY

Points Rules

Quick Reply Top Back to list