Umi Plus deceased?

Pattieman Post time 4 Day Before | Show all posts [Copy link]
11 801
View: 801|Reply: 11

Umi Plus deceased?

[Copy link]

1

threads

2

posts

12

credits

New Member

Rank: 1

credits
12
Post time 2016-12-28 18:55:38 | Show all posts |Read mode
Received my 7th Umi, this time a Plus.
Nice phone, installed with dual sims and everything else.

Noticed after 3 days that the phone went off after charging it at night and had trouble booting up.
After 3 more days the phone is not booting at all and does nothing.
No charging light and also another charger or cable does nothing.

When connecting to computer you hear a sound, but then another sound and another and another etc.
Computer does not show device and device not responding to connection.
First thought was that the screen was busted (by itself ?), but there is also no backlight, had an Umi Super who did the same thing and had to send it back. (3 months ago, still not back)
Phone appears dead, don not ask me why.

Now I am forced to contact seller, but I know exactly what chinese companies do in comparison to european companies.
I have to make a video ( not to much Mb off course ) to show the problem and then after a while send it to them.
This will surely take months.
I love doing business with chinese phones, but I hate the customer service.
it is off course the main reason that not everybody is buying phones in China.

Is there anybody out there who had the same issue?
         

8

threads

63

posts

248

credits

Platinum Member

Rank: 3Rank: 3

credits
248
Post time 2016-12-28 19:10:27 | Show all posts
The issue regarding PC recognition can be easily fixed by installing a default USB driver in devices management. There is a topic in this forum with each step. The charging issue might be due to the fact that the type C end tends to disconnect easily, make sure to push it all the way through and dont shake the phone top much when charging

1

threads

2

posts

12

credits

New Member

Rank: 1

credits
12
 Author| Post time 2016-12-28 21:37:52 | Show all posts
Like I mentioned I have multiple Umi's and know how to flash and connect to PC.
The Umi Plus stopped working and is not charging with whatever charger I use.
Thanks for the advice, but I think this is a hopeless case.

1

threads

2636

posts

6415

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
6415
Post time 2016-12-28 23:37:05 | Show all posts
Pattieman replied at 2016-12-28 21:37
Like I mentioned I have multiple Umi's and know how to flash and connect to PC.
The Umi Plus stopped ...

Firstly you need check charger and USB wire (swap with other phone charger) try charge minimum 1 hours.
If phone won't recover you need flash your phone with SPFT using computer and one of the ROMs from here. Firstly please choose firmware upgrade but if not help choose format all + download.
http://community.umidigi.com/forum-131-1.html
If still won't recover contact reseller.
There must be something wrong with your phone using as you mentioned umi super and umi plus got exactly same fault. Maybe you should stop charging phones over whole night.

1

threads

3

posts

24

credits

New Member

Rank: 1

credits
24
Post time 2017-8-11 03:06:35 | Show all posts
It seems I just got identical issue. The only thing that works are those sounds in Windows 10. Sometimes red LED will light up for few seconds, when I move the cable (like once every 20 tries), but that's all. Same issues with non-original cables.
Although my UMI PLUS died after several tries of turning it on. It worked for a while, but battery never showed more, than 1% (and it died for a first time, when I recharged it for few minutes, with battery at 53%).

5

threads

94

posts

398

credits

Platinum Member

Rank: 3Rank: 3

credits
398
Post time 2017-8-11 14:34:03 | Show all posts
Lol another "Umistery"...

0

threads

1

posts

4

credits

New Member

Rank: 1

credits
4
Post time 2017-8-20 16:53:49 | Show all posts
Hello there Pattieman, I have read your thoughts about the Umi plus phone which I also own as of the moment. I have the same issue with you. I bought this phone online, and since the third-party online store required me to contact the UMI seller specifically the UMI manufacturer, I am advised to return my phone back to China. But then I have second thoughts knowing that I have read your comment about how bad their customer service is. I just need pieces of your advice, before I will finally send back my phone to the UMIDIGI warehouse.

0

threads

1

posts

10

credits

New Member

Rank: 1

credits
10
Post time 2017-8-21 18:06:17 | Show all posts
Bonjour
Je vois que je ne suis pas le seul au monde à avoir acheté un Umi plus qui ne fonctionne plus pour ma part au bout de 8 mois. Comme vous le voyant de charge s'allume sans emettre de son et s'eteint au bout de 3 minutes. Connection impossible au micro (non reconnu) Le vendeur me demande des explications ensuite de faire une vidéo sur la toile, je n'ai plus de téléphone je la fais avec quoi, je lui propose de lui renvoyer le produit, depuis 5 jours ils ne répondent pus à mes mails bravo. Acheté sur le site Coolicool bravo pour le manque de professionnalisme je vous déconseille d'acheter chez eux.

1

threads

8

posts

47

credits

New Member

Rank: 1

credits
47
Post time 7 Day Before | Show all posts
Same with me...

0

threads

1

posts

16

credits

New Member

Rank: 1

credits
16
Post time 4 Day Before | Show all posts
Edited by JimboAccy at 2017-10-20 00:04 \n\nFor some reason I cant post a new thread - but my Umi Plus is dead too.  Reseller DealExtreme say they wont repair it as its out of warranty despite on Umi's website on the service page at the bottom it says all Umi products have a 2 year warranty - this is just over a year old so looking for someone in UK that can repair this - anyone know of anyone?  Desperate to get it fixed as its a great phone.  I moved house, plugged it in using the Qualcomm 2.0 fast charger and could hear a ticking noise coming from the charger so assumed the charger was faulty.  I bought a new Qualcomm 3.0 fast charger as a replacement - it worked 2 or 3 times, then the third time it was charging whilst powered off and I went to check it and the battery level was 53%, put it down and then I could smell burining so checked the new charger and it was very hot. I unplugged it and now the phone wont power on at all and wont charge at all.  No LED on the phone to indicate its plugged in and Ive tried to connect it to my PC but nothing there either.  This is with the original UMI usb-c cable that came with the device.  Ive been given a full refund on the new faulty charger as I only had that 10 days before it 'melted' but I doubt they will pay for the damage to my phone as well.  Any one any suggestions for UK repairs?  I don't want to take the phone to bits myself....

Thanks
Jimbo
12Next
You have to log in before you can reply Login | WELCOME TO UMI COMMUNITY

Points Rules

!fastreply! Top !return_list!