UMI PLUS forgotten in rain

Mooyldz Post time 2017-10-6 01:16:13 | Show all posts [Copy link]
5 294
View: 294|Reply: 5

UMI PLUS forgotten in rain

[Copy link]

1

threads

1

posts

5

credits

New Member

Rank: 1

credits
5
Post time 2017-7-4 06:09:01 | Show all posts |Read mode
Edited by Mooyldz at 2017-7-4 06:11 \n\nHello
I feel really embarrassed. I forgot my phone in the rain for about 1h while playing tennis, yes in  the rain. I did everything I should not, i used the phone just after figuring it was wet to send a message then it started to act up. The Screen began flashing color fading. I switched off the phone. Then it completely stopped working for a while and the led notifications were in every color flashing repeatedly. Then i read a few things like drying with hair dryer or putting straight in rice box for 3 days. Which i tried. I did not use the hair drier too much because I knew it would be dangerous. Used it very low heat from far. My UMI plus started working but now the screen is constantly flashing with a white color. Also colorful stripes appears the more I use the phone.

I am really annoyed because this is my favorite phone ever. I do think that it is too late to repair but I need some opinion. The Umi plus seems impossible to disassemble and repair. I may order another one. The phone is still very responsive but battery charges very slowly and drains very quickly since then. Only thing is the screen hurts my eyes.  

Thanks for reading.

Regards
         

1

threads

2752

posts

6753

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
6753
Post time 2017-7-5 07:12:42 | Show all posts
Is very easy to dismantle this phone if you know what you doing and you have some tools. Most tutorials are on YouTube so you should check there. I think that cheaper and more safe will be buy new phone and keep this one for spare parts as you probably will be very hard to diagnose correctly your phone as water could damage everything including motherboard which is hard to get and expensive.

0

threads

16

posts

87

credits

Senior Member

Rank: 2

credits
87
Post time 2017-10-5 04:48:41 | Show all posts
My UMIDIGI Plus e has not been in the rain, but has acted strange for the last few weeks:

Once in a while, when I unlock it, it starts vibrating, and would not stop unless I press the power button, and put it back to sleep.
At the same time, the screen is hardly responding, very unstable, comes right back to Home page, and does not allow me to launch any App.
I can't even get to the "Power Off / Retart / Airplane Mode" to reboot it.

The only (not practical!) solution I've found so far was to take it apart, disconnect the battery cable, reassemble, and reboot.
It fixes it for a while: Sometimes for a few days or a week, sometimes just for a few hours.

I have no idea what triggers this.

In the mean time, I have ordered a S1 Pro, which I just received, but I'd still like to get my Plus e working as it should, as it's definitely a great phone.

1

threads

2752

posts

6753

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
6753
Post time 2017-10-5 05:30:58 | Show all posts
Edited by MarcinP at 2017-10-5 06:03 \n\n
phrvo replied at 2017-10-5 04:48
My UMIDIGI Plus e has not been in the rain, but has acted strange for the last few weeks:

Once in a ...

You talking very strange things as Umidigi S2 pro is in pre sale and you saying that you received this device.
Another thing is that this is Umi plus thread not Umi plus E.
If your phone is freezed and screen is not responding you need press power button for around 10 seconds to switch off phone and then you can reboot.
When your phone is working go to settings - backup and reset - factory reset.
Also go to settings - about phone - wireless update.
Here please compare firmware build number and if is not latest and OTA update not working use OTA zip file from each thread and follow instruction.
http://community.umidigi.com/forum-128-1.html
If nothing is helping please flash system with SPFT.
Here is SPFT instruction
http://community.umidigi.com/forum.php?mod=viewthread&tid=11I thought that you talking about S2 Pro but you actually mention S1 pro which is not existing. Maybe you speaking about Z1 Pro?


0

threads

16

posts

87

credits

Senior Member

Rank: 2

credits
87
Post time 2017-10-5 16:48:21 | Show all posts
Nope...
I said I received my S1 (ONE) Pro... NOT S2 :-)

0

threads

16

posts

87

credits

Senior Member

Rank: 2

credits
87
Post time 2017-10-6 01:16:13 | Show all posts
Oooops, it's a Z1 Pro :-(
You have to log in before you can reply Login | WELCOME TO UMI COMMUNITY

Points Rules

!fastreply! Top !return_list!